# APM Service Map Internal Server Error

**URL:** <https://discuss.elastic.co/t/apm-service-map-internal-server-error/252451>\
**Category:** APM\
**Tags:** ui\
**Created:** [October 18, 2020, 12:40pm UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error/252451 "2020-10-18T12:40:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![elastic\_study](https://avatars.discourse-cdn.com/v4/letter/e/ee7513/32.png) [@elastic\_study](https://discuss.elastic.co/u/elastic_study)\
**Post date:** [October 18, 2020, 12:40pm UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error/252451/1 "2020-10-18T12:40:05Z")

</div>

The service map of APM module in kibana(7.8.0) is wrong, and other functions of APM are normal  
error log in kibana:  
//-------------------  
log [12:31:19.820] [error][http] { Error: [resource\_not\_found\_exception] No known job with id 'apm'  
at respond (/opt/kibana-7.8.0-linux-x86\_64/node\_modules/elasticsearch/src/lib/transport.js:349:15)  
at checkRespForFailure (/opt/kibana-7.8.0-linux-x86\_64/node\_modules/elasticsearch/src/lib/transport.js:306:7)  
at HttpConnector. (/opt/kibana-7.8.0-linux-x86\_64/node\_modules/elasticsearch/src/lib/connectors/http.js:173:7)  
at IncomingMessage.wrapper (/opt/kibana-7.8.0-linux-x86\_64/node\_modules/elasticsearch/node\_modules/lodash/lodash.js:4929:19)  
at IncomingMessage.emit (events.js:203:15)  
at endReadableNT (\_stream\_readable.js:1145:12)  
at process.\_tickCallback (internal/process/next\_tick.js:63:19)  
status: 404,  
displayName: 'NotFound',  
message:  
'[resource\_not\_found\_exception] No known job with id 'apm'',  
path: '/\_ml/anomaly\_detectors/apm',  
query: {},  
body:  
{ error:  
{ root\_cause: [Array],  
type: 'resource\_not\_found\_exception',  
reason: 'No known job with id 'apm'' },  
status: 404 },  
statusCode: 404,  
response:  
'{"error":{"root\_cause":[{"type":"resource\_not\_found\_exception","reason":"No known job with id 'apm'"}],"type":"resource\_not\_found\_exception","reason":"No known job with id 'apm'"},"status":404}',  
toString: [Function],  
toJSON: [Function] }  
error [12:31:19.757] Error: Internal Server Error  
at HapiResponseAdapter.toInternalError (/opt/kibana-7.8.0-linux-x86\_64/src/core/server/http/router/response\_adapter.js:69:19)  
at Router.handle (/opt/kibana-7.8.0-linux-x86\_64/src/core/server/http/router/router.js:163:34)  
at process.\_tickCallback (internal/process/next\_tick.js:68:7)  
//-------------------  
kibana web error  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/1/511b0d327a149b38df6ad2cdd75102ecb6f6e8ed.png)

Please give me some advice！

---

<div class="post-metadata">

**Author:** ![smith](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smith/32/53043_2.png) [@smith](https://discuss.elastic.co/u/smith)\
**Post date:** [October 18, 2020, 3:14pm UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error/252451/2 "2020-10-18T15:14:54Z")

</div>

This is a known issue in 7.8.0. A workaround is to create an ML job or to upgrade to 7.8.1 or newer.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 8, 2020, 11:14am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error/252451/3 "2020-11-08T11:14:55Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
