# APM transactions from one specific service aren't shipping

**URL:** <https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853>\
**Category:** APM\
**Tags:** nodejs, server\
**Created:** [November 6, 2019, 7:01pm UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853 "2019-11-06T19:01:49Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![michaelbdavidson7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelbdavidson7/32/57016_2.png) [@michaelbdavidson7](https://discuss.elastic.co/u/michaelbdavidson7)\
**Post date:** [November 6, 2019, 7:01pm UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/1 "2019-11-06T19:01:49Z")

</div>

Elastic cloud running 7.0

**APM Server version** :  
Whichever comes with EC 7.0, which

**APM Agent language and version** :  
npm version - elastic-apm-node v2.13.0

Issue:  
Hi, we're using elastic cloud APM in our four applications. Three are sending logs fine, but the fourth is not sending transactions specifically. It is sending errors and non-transaction-related metrics just fine. I deleted the index in kibana a while ago and it was around then that it stopped getting those transactions. Could it just have never recovered ? is there a way to fix this from kibana?

Additional info: I went to the Discover page in kibana and could see everything except for the transactions from that fourth service.

Thanks guys.

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [November 7, 2019, 11:28am UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/2 "2019-11-07T11:28:51Z")

</div>

Hi @michaelbdavidson7, welcome to the forum!

Have you already enabled trace logging? If not, I'd recommend following [https://www.elastic.co/guide/en/apm/agent/nodejs/current/troubleshooting.html#debug-mode](https://www.elastic.co/guide/en/apm/agent/nodejs/current/troubleshooting.html#debug-mode) to do that, and look out for any error responses from the server. That might give us some more clues.

---

<div class="post-metadata">

**Author:** ![michaelbdavidson7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelbdavidson7/32/57016_2.png) [@michaelbdavidson7](https://discuss.elastic.co/u/michaelbdavidson7)\
**Post date:** [November 8, 2019, 8:07pm UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/3 "2019-11-08T20:07:22Z")

</div>

Hi Andrew,  
Thanks for the reply. I did this locally, and didn't see any errors thrown. I now see that I don't think some of the APM errors are crossing over either..  
What else could it be?  
This used to work, I think it was from when I was messing with ES. is there a way I can just reset my ES index or something?

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [November 12, 2019, 2:57am UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/4 "2019-11-12T02:57:36Z")

</div>

> [@michaelbdavidson7](#):
>
> Thanks for the reply. I did this locally, and didn't see any errors thrown. I now see that I don't think some of the APM errors are crossing over either..  
> What else could it be?  
> This used to work, I think it was from when I was messing with ES. is there a way I can just reset my ES index or something?

You could blow away the indices again, but I'm not convinced that'll help. I suggest checking the APM Server logs to see if there is any strange showing up there. It seems pretty odd that you would be receiving _some_ but not all errors from the service - unless it's a short-lived service, and it's failing to flush data to the server. But then I wouldn't expect you to be seeing metrics either.

One thing that can cause data to be dropped is when labels have different types across services. If one service is recording transactions with a label `foo: <number>` and another service records transactions with a label `foo: <string>`, then the server will fail to record them for one or the other. You should see an error in the agent, though.

---

<div class="post-metadata">

**Author:** ![michaelbdavidson7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelbdavidson7/32/57016_2.png) [@michaelbdavidson7](https://discuss.elastic.co/u/michaelbdavidson7)\
**Post date:** [November 15, 2019, 4:49pm UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/5 "2019-11-15T16:49:47Z")

</div>

hey this was a code issue on our part, we imported our routes before the APM so the APM wasn't watching them ..  
Thanks!

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [November 18, 2019, 1:06am UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/6 "2019-11-18T01:06:58Z")

</div>

Ahhh! Glad to hear it's sorted.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2019, 9:07pm UTC](https://discuss.elastic.co/t/apm-transactions-from-one-specific-service-arent-shipping/206853/7 "2019-12-08T21:07:03Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
