# APM UI query bar broken

**URL:** <https://discuss.elastic.co/t/apm-ui-query-bar-broken/219595>\
**Category:** APM\
**Created:** [February 17, 2020, 10:25am UTC](https://discuss.elastic.co/t/apm-ui-query-bar-broken/219595 "2020-02-17T10:25:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![heydo](https://avatars.discourse-cdn.com/v4/letter/h/a587f6/32.png) [@heydo](https://discuss.elastic.co/u/heydo)\
**Post date:** [February 17, 2020, 10:25am UTC](https://discuss.elastic.co/t/apm-ui-query-bar-broken/219595/1 "2020-02-17T10:25:27Z")

</div>

**Kibana version** : 7.5.1

**Elasticsearch version** : 7.5.1

**APM Server version** : 7.5.1

**APM Agent language and version** : Java Agent on version 1.12.0

**Is there anything special in your setup?** All services run on docker

**Description of the problem including expected versus actual behavior** :  
Actual behavior: When I type something in the query bar at the APM UI, I get no suggestions, and when I insert a search request, nothing happens. I do have results listed, and can see the fields that I try to query when I click on them.

 ![Actual behavior](https://us1.discourse-cdn.com/elastic/original/3X/b/b/bb6305b964d622e9b444fa8bbfe1ac091b9adefd.png)

Expected behavior: When I type in the query bar, I get suggestions, and when I enter queries they filter the results.

 ![Expected behavior](https://us1.discourse-cdn.com/elastic/original/3X/8/d/8d0984cf9a576c217bf66a3f232ec80e4e18dd36.png)

The error first occurred when I changed infra configurations in Kibana, but reversing these changes doesn't help. The query bar works on all other places in Kibana, and I can filter results from the apm-\* index pattern on the Discovery page.  
I have also not found any relevant logs or errors.

Thanks for your help!

---

<div class="post-metadata">

**Author:** ![heydo](https://avatars.discourse-cdn.com/v4/letter/h/a587f6/32.png) [@heydo](https://discuss.elastic.co/u/heydo)\
**Post date:** [February 17, 2020, 4:20pm UTC](https://discuss.elastic.co/t/apm-ui-query-bar-broken/219595/2 "2020-02-17T16:20:19Z")

</div>

I solved it: When Kibana starts, my setup manually configured an index-pattern with the correct name, but not with the correct fields. Because I used the default values in apm-server.yml, APM did not overwrite the pattern with the correct one (that it otherwise configures automatically). Because the query bar needs searchable fields defined in the index pattern to query them, I could not use the bar.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 9, 2020, 12:20pm UTC](https://discuss.elastic.co/t/apm-ui-query-bar-broken/219595/3 "2020-03-09T12:20:19Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
