# APM - Unexpected timeouts occurring

**URL:** <https://discuss.elastic.co/t/apm-unexpected-timeouts-occurring/150764>\
**Category:** APM\
**Created:** [October 2, 2018, 8:27pm UTC](https://discuss.elastic.co/t/apm-unexpected-timeouts-occurring/150764 "2018-10-02T20:27:07Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mike\_H](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike_h/32/33104_2.png) [@Mike\_H](https://discuss.elastic.co/u/Mike_H)\
**Post date:** [October 2, 2018, 8:27pm UTC](https://discuss.elastic.co/t/apm-unexpected-timeouts-occurring/150764/1 "2018-10-02T20:27:07Z")

</div>

Hi There, big fans of APM.

However, we are now getting timeout errors between the python agent and the apm server. We're on Python 3.6.6, Django 2.1.2 and Elasticsearch/Kibana/APM 6.4.1.

Previously, APM worked fine, but we've upgraded both Django and APM, and now timeouts are being thrown.

When running`python manage.py elasticapm check`, I get success messages.

When running `python manage.py elasticapm test`, I get `PID 29: ElasticAPM is attempting to send 1 pending messages`

When running the APM tutorial from the kibana dashboard, that is successful.

However, the APM dashboard shows the message, "No services found".

We're seeing regular errors like: `[elasticapm.errors] [ERROR] Connection to APM Server timed out (url: http://elastic-apm.default.svc.cluster.local:8200/v1/transactions, timeout: None seconds)`

All of this is deployed on kubernetes cluster, and we previously had this working by following the documented setup, so I'm not sure what we're missing.

Here's the relevant section from our `settings.py`

```
ELASTIC_APM = {
  'SERVICE_NAME': 'elastic-apm',
  'SERVER_URL': 'http://elastic-apm.default.svc.cluster.local:8200',
  'SERVER_TIMEOUT': 60,
  'DEBUG': True,
}

```

apm-server.host has a value of `0.0.0.0:8200`

Help is much appreciated! 😀

---

<div class="post-metadata">

**Author:** ![Mike\_H](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike_h/32/33104_2.png) [@Mike\_H](https://discuss.elastic.co/u/Mike_H)\
**Post date:** [October 3, 2018, 12:58am UTC](https://discuss.elastic.co/t/apm-unexpected-timeouts-occurring/150764/2 "2018-10-03T00:58:17Z")

</div>

Turns out it was an issue with our kubernetes cluster, which is still weird since we don't recall changing anything other than package versions, but nonetheless, it appears to be something other than APM.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 23, 2018, 8:58pm UTC](https://discuss.elastic.co/t/apm-unexpected-timeouts-occurring/150764/3 "2018-10-23T20:58:22Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
