# App-Search failed to connect to Elasticsearch backup

**URL:** <https://discuss.elastic.co/t/app-search-failed-to-connect-to-elasticsearch-backup/222716>\
**Category:** Elastic Search\
**Tags:** docker, elastic-app-search\
**Created:** [March 9, 2020, 1:35pm UTC](https://discuss.elastic.co/t/app-search-failed-to-connect-to-elasticsearch-backup/222716 "2020-03-09T13:35:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Austin\_Lai](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/austin_lai/32/64056_2.png) [@Austin\_Lai](https://discuss.elastic.co/u/Austin_Lai)\
**Post date:** [March 9, 2020, 1:35pm UTC](https://discuss.elastic.co/t/app-search-failed-to-connect-to-elasticsearch-backup/222716/1 "2020-03-09T13:35:01Z")

</div>

Hi anyone solved or encounter issue with app-search?

[2020-03-09T13:31:14.528+00:00][14][2002][app-server][INFO]: Failed to connect to Elasticsearch backend. Make sure it is running.

```
app-search7.6.1:

    image: docker.elastic.co/app-search/app-search:7.6.1

    container_name: app-search7.6.1

    hostname: app-search7.6.1

    restart: always

    links:

      - elasticsearch7.6.1

      - kibana7.6.1

    depends_on:

      - elasticsearch7.6.1

      - kibana7.6.1

    user: root #To read the docker socket

    ports:

      - 38887:3002

    expose: 

      - 38887

    environment:

      - secret_session_key=supersecretsessionkey

      - setup.kibana.host=["http://kibana7.6.1:5601"]

      - output.elasticsearch.hosts=["http://elasticsearch7.6.1:9200"]

      - "allow_es_settings_modification=true"

      - "JAVA_OPTS=-Xmx256m -Xmx256m"

    networks:

        - elastic

```

---

<div class="post-metadata">

**Author:** ![orhantoy](https://avatars.discourse-cdn.com/v4/letter/o/c5a1d2/32.png) [@orhantoy](https://discuss.elastic.co/u/orhantoy)\
**Post date:** [March 27, 2020, 2:40pm UTC](https://discuss.elastic.co/t/app-search-failed-to-connect-to-elasticsearch-backup/222716/2 "2020-03-27T14:40:07Z")

</div>

`setup.kibana.hosts` and `output.elasticsearch.hosts` are not App Search config options.  
You can see what they are called in App Search [here](https://swiftype.com/documentation/app-search/self-managed/configuration); my guess is that you have to remove `setup.kibana.hosts` and then replace

```auto
- output.elasticsearch.hosts=["http://elasticsearch7.6.1:9200"]

```

with

```auto
- elasticsearch.host=http://elasticsearch7.6.1:9200

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 24, 2020, 2:40pm UTC](https://discuss.elastic.co/t/app-search-failed-to-connect-to-elasticsearch-backup/222716/3 "2020-04-24T14:40:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
