# Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>"https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/", :error\_type=\>LogStash:error=\>"Elasticsearch Unreachable: \[https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/\]

**URL:** <https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676>\
**Category:** Logstash\
**Tags:** elastic-stack-monitoring, elastic-stack-security\
**Created:** [April 19, 2022, 7:24am UTC](https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676 "2022-04-19T07:24:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sahir](https://avatars.discourse-cdn.com/v4/letter/s/7cd45c/32.png) [@sahir](https://discuss.elastic.co/u/sahir)\
**Post date:** [April 19, 2022, 7:24am UTC](https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676/1 "2022-04-19T07:24:44Z")

</div>

Hi Team, I tried to connect Elasticsearch from Logstash i'm facing this error. I deployed Elasticsearch using HTTPS and check without passing a certificate its shows an error Elastic hosts is unreachable and again ill tested with the Elasticsearch certficate passing through logsatsh config file like this

```nohighlight
        hosts => ["https://xxxxxxx:9200"]
        user => 'xxxxx'
        password => 'xxxxxxxx'
        index => "logstash-beta-%{+YYYY.MM.dd}"
        ssl => true
        ssl_certificate_authorities => ["/etc/secret-volume/ca.crt"]
        ssl_certificate => "/etc/secret-volume/tls.crt"
        ssl_key => "/etc/secret-volume/tls.key"

I passed the cert file and path like this again im getting the error like 

```

elastcisearch - unknown setting ssl\_certificate\_authority  
elastcisearch - unknown setting ssl\_certificate  
elastcisearch - unknown setting ssl\_key

Then i removed these three lines and checked again it shows an error like

Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>"[https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/](https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/)", :error\_type=\>LogStash::Outputs::Elasticsearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/](https://elastic:xxxxxx@xxx.xxx.xx.xx:9200/)][Manticore::ClientProtocolException] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"}

```auto

How can i connect with Elasticsearch and can you please explain how to pass the cert and key through logstash config file.
```

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [April 20, 2022, 3:04am UTC](https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676/2 "2022-04-20T03:04:19Z")

</div>

You only need the CA certificate, and the name of the config is `cacert`, not `ssl_certificate_authority` , check [Secure your connection to Elasticsearch | Logstash Reference [8.1] | Elastic](https://www.elastic.co/guide/en/logstash/current/ls-security.html#es-sec-plugin)

---

<div class="post-metadata">

**Author:** ![sahir](https://avatars.discourse-cdn.com/v4/letter/s/7cd45c/32.png) [@sahir](https://discuss.elastic.co/u/sahir)\
**Post date:** [April 20, 2022, 11:32am UTC](https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676/3 "2022-04-20T11:32:23Z")

</div>

@ikakavas Thanks for your reply, I did the same you suggest to me instead of ssl\_certificate\_authority i used cacert but again i'm getting error like

```auto
[ERROR] 2022-04-20 10:33:04.543 [[main]-pipeline-manager] javapipeline - Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<Manticore::UnknownException: Host name 'xxx.xxx.xx.xx' does not match the certificate subject provided by the peer (CN=elasticsearch-es-http.accuknox-dev-logging.es.local, OU=elasticsearch)>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:37:in `block in initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:79:in `call'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/manticore_adapter.rb:74:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:332:in `perform_request_to_url'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:261:in `health_check_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:270:in `block in healthcheck!'", "org/jruby/RubyHash.java:1415:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:266:in `healthcheck!'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:382:in `update_urls'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:82:in `update_initial_urls'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:76:in `start'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client.rb:302:in `build_pool'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client.rb:64:in `initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client_builder.rb:103:in `create_http_client'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/http_client_builder.rb:99:in `build'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch.rb:266:in `build_client'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.4.2-java/lib/logstash/outputs/elasticsearch/common.rb:24:in `register'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:126:in `register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:68:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:216:in `block in register_plugins'", "org/jruby/RubyArray.java:1809:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:215:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:520:in `maybe_setup_out_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:228:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:170:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:125:in `block in start'"], "pipeline.sources"=>["/usr/share/logstash/pipeline/logstash.conf"], :thread=>"#<Thread:0x179cb7c9@/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:121 run>"}
[ERROR] 2022-04-20 10:33:04.565 [Converge PipelineAction::Create<main>] agent - Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[INFO] 2022-04-20 10:33:04.633 [Api Webserver] agent - Successfully started Logstash API endpoint {:port=>9600}
[INFO] 2022-04-20 10:33:09.649 [LogStash::Runner] runner - Logstash shut down.

```

can you please help me to connect logstash and Elasticsearch  
This is the configuration file currently im using now.

```auto
output {
      elasticsearch {
       hosts => ["https://<NodeIP>:9200"]
       ssl => true
       ssl_certificate_verification => true
       cacert => "<Path to: cluster-ca-certificate.pem>"
       user => "<LogstashUserName>"
       password => "<LogstashPassword>"
       index => "testdata"
       ilm_enabled => false
}
 stdout {}
}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 18, 2022, 11:33am UTC](https://discuss.elastic.co/t/attempted-to-resurrect-connection-to-dead-es-instance-but-got-an-error-url-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200-error-type-logstash-error-elasticsearch-unreachable-https-elastic-xxxxxx-xxx-xxx-xx-xx-9200/302676/4 "2022-05-18T11:33:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
