# Authentication of \[elastic\] was terminated by realm \[reserved\] - failed to authenticate user \[elastic\]

**URL:** <https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996>\
**Category:** Elasticsearch\
**Created:** [December 2, 2017, 3:57am UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996 "2017-12-02T03:57:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [December 2, 2017, 3:57am UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996/1 "2017-12-02T03:57:20Z")

</div>

I'm trying to get started with follow [Install Elasticsearch with Docker | Elasticsearch Reference [6.0] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html), and even though I set initial password with Docker environment variable _ELASTIC\_PASSWORD_ and as I start it, I noticed following in logs:

> elasticsearch | [2017-12-02T03:42:55,095][INFO][o.e.x.s.a.AuthenticationService] [770ea4c1e78f] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

however, I keep seeing failed attempts of authentication (not mine) as I'm able to login without any issues:

```
# curl -I http://elastic:MagicWord@0:9200
HTTP/1.1 200 OK
content-type: application/json; charset=UTF-8
content-length: 431

# 

```

Please advise.

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [December 6, 2017, 7:46pm UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996/2 "2017-12-06T19:46:10Z")

</div>

Are you running Kibana, Logstash, Beats, or anything else that is trying to connect to your Elasticsearch?

---

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [December 6, 2017, 8:31pm UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996/3 "2017-12-06T20:31:07Z")

</div>

sorry, I couldn't find at first what was trying to access it, but later on I found

so never mind)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 3, 2018, 8:31pm UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/109996/4 "2018-01-03T20:31:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
