# AWS SNS not getting metrics, return a weird error

**URL:** <https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [February 25, 2020, 5:45am UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771 "2020-02-25T05:45:14Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![odirionyeo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/odirionyeo/32/63245_2.png) [@odirionyeo](https://discuss.elastic.co/u/odirionyeo)\
**Post date:** [February 25, 2020, 5:45am UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771/1 "2020-02-25T05:45:14Z")

</div>

Hello, I deployed the ELK stack on Kubernetes. I have configured all the metrics for AWS SNS, SQS, Cloudwatch, etc. All the metrics setup on metricbeat works but SNS metric set returns a weird error.  
Here is my config:  
`module: aws labels.dedot: true metricsets: - ec2 - s3_request - s3_daily_storage - rds - sqs - sns - elb - cloudwatch metrics: - namespace: "AWS/ElastiCache" - namespace: "AWS/SNS" - namespace: "AWS/SQS" - namespace: "AWS/RDS" period: 300s access_key_id: '${AWS_ACCESS_KEY_ID:""}' secret_access_key: '${AWS_SECRET_ACCESS_KEY:""}' session_token: '${AWS_SESSION_TOKEN:""}' default_region: '${AWS_REGION:eu-west-1}'`

Here is my error

 ![Here is my error](https://us1.discourse-cdn.com/elastic/original/3X/4/c/4cd1818e7d3abeeef8698728afd8bcf14d92d3fb.png)

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [March 16, 2020, 8:01pm UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771/2 "2020-03-16T20:01:16Z")

</div>

I've moved this to the metricbeat topic since it doesn't appear that this post has anything to do with heartbeat.

---

<div class="post-metadata">

**Author:** ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)\
**Post date:** [March 23, 2020, 4:28pm UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771/3 "2020-03-23T16:28:48Z")

</div>

Hi @odirionyeo, is this error from on a specific part of the dashboard? Have you tried refresh the kibana index by navigating to Management \> Index patterns and "Refresh" the index you're using (most likely, "metricbeat")?

---

<div class="post-metadata">

**Author:** ![odirionyeo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/odirionyeo/32/63245_2.png) [@odirionyeo](https://discuss.elastic.co/u/odirionyeo)\
**Post date:** [April 10, 2020, 8:13pm UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771/4 "2020-04-10T20:13:34Z")

</div>

We were able to fix this issue, there was no data on cloudwatch for pulling the metrics. Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2020, 8:13pm UTC](https://discuss.elastic.co/t/aws-sns-not-getting-metrics-return-a-weird-error/220771/5 "2020-05-08T20:13:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
