# Azure snapshot issue - getting: blob\_storage\_exception","reason":"Status code 400, "﻿\\nBlobTypeNotSupportedBlock blobs are not supported

**URL:** <https://discuss.elastic.co/t/azure-snapshot-issue-getting-blob-storage-exception-reason-status-code-400-nblobtypenotsupportedblock-blobs-are-not-supported/328690>\
**Category:** Elasticsearch\
**Tags:** docker, snapshot-and-restore\
**Created:** [March 28, 2023, 8:49am UTC](https://discuss.elastic.co/t/azure-snapshot-issue-getting-blob-storage-exception-reason-status-code-400-nblobtypenotsupportedblock-blobs-are-not-supported/328690 "2023-03-28T08:49:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mariusko82](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mariusko82/32/119046_2.png) [@Mariusko82](https://discuss.elastic.co/u/Mariusko82)\
**Post date:** [March 28, 2023, 8:49am UTC](https://discuss.elastic.co/t/azure-snapshot-issue-getting-blob-storage-exception-reason-status-code-400-nblobtypenotsupportedblock-blobs-are-not-supported/328690/1 "2023-03-28T08:49:57Z")

</div>

### Elasticsearch Version

Version: 8.2.3, Build: default/docker/9905bfb62a3f0b044948376b4f607f70a8a151b4/2022-06-08T22:21:36.455508792Z, JVM: 18.0.1.1

### Installed Plugins

_No response_

### Java Version

_bundled_

### OS Version

Linux elasticsearch-ss-0 5.4.0-1103-azure [#109](https://github.com/elastic/elasticsearch/issues/109)~18.04.1-Ubuntu SMP Wed Jan 25 20:53:00 UTC 2023 x86\_64 x86\_64 x86\_64 GNU/Linux

### Problem Description

We are not able to create, verify and use repository in Azure storage account. We are receiving the following message:  
`curl -X PUT "localhost:9200/*snapshot/lab_backup/%3Cmy_snapshot*%7Bnow%2Fd%7D%3E?pretty" { "accepted" : true } elasticsearch@elasticsearch-ss-0:~$ curl -X PUT "localhost:9200/*snapshot/lab_backup/lab_snapshot* `date +"%Y.%m.%d"`?wait_for_completion=true" {"error":{"root_cause":[{"type":"snapshot_exception","reason":"[lab_backup:lab_snapshot_2023.03.27/Jf2Dej8lTqOQ0L3kYXf8yg] failed to update snapshot in repository"}],"type":"snapshot_exception","reason":"[lab_backup:lab_snapshot_2023.03.27/Jf2Dej8lTqOQ0L3kYXf8yg] failed to update snapshot in repository","caused_by":{"type":"blob_storage_exception","reason":"Status code 400, " \n`BlobTypeNotSupported`Block blobs are not supported.\nRequestId:bc4cb5e8-a01c-004b-4985-60dd95000000\nTime:2023-03-27T08:24:16.9573320Z"","suppressed":[{"type":"exception","reason":"#block terminated with an error"},{"type":"blob_storage_exception","reason":"Status code 400, " \n`BlobTypeNotSupported`Block blobs are not supported.\nRequestId:bc4cb5f6-a01c-004b-5785-60dd95000000\nTime:2023-03-27T08:24:16.9712714Z"","suppressed":[{"type":"exception","reason":"#block terminated with an error"}]},{"type":"blob_storage_exception","reason":"Status code 400, " \n`BlobTypeNotSupported`

elasticsearch@elasticsearch-ss-0:~$ curl -X PUT "localhost:9200/\_snapshot/lab\_backup?pretty" -H 'Content-Type: application/json' -d'  
{  
"type": "azure",  
"settings": {  
"client": "default",  
"container": "backupes"  
}  
}  
'  
{  
"acknowledged" : true  
} `

### Steps to Reproduce

1. create Azure storage account of type StorageV2 (general purpose v2), performance Premium, replication Locally-redundant storage (LRS). Into this SA create container "backupes".
2. Create keystore (bin/elasticsearch-keystore add azure.client.default.key). with account name and secret.
3. create repository:'\</\>elasticsearch@elasticsearch-ss-0:~~$ curl -X PUT "localhost:9200/\_snapshot/lab\_backup?pretty" -H 'Content-Type: application/json' -d'  
{  
"type": "azure",  
"settings": {  
"client": "default",  
"container": "backupes"  
}  
}  
'  
{  
"acknowledged" : true  
}  
4.send snapshot to the repository:elasticsearch@elasticsearch-ss-0:~~$ curl -X PUT "localhost:9200/_snapshot/lab\_backup/lab\_snapshot_ `date +"%Y.%m.%d"`?wait\_for\_completion=true"  
{"error":{"root\_cause":[{"type":"snapshot\_exception","reason":"[lab\_backup:lab\_snapshot\_2023.03.27/Jf2Dej8lTqOQ0L3kYXf8yg] failed to update snapshot in repository"}],"type":"snapshot\_exception","reason":"[lab\_backup:lab\_snapshot\_2023.03.27/Jf2Dej8lTqOQ0L3kYXf8yg] failed to update snapshot in repository","caused\_by":{"type":"blob\_storage\_exception","reason":"Status code 400, " \n`BlobTypeNotSupported`Block blobs are not supported.\nRequestId:bc4cb5e8-a01c-004b-4985-60dd95000000\nTime:2023-03-27T08:24:16.9573320Z"","suppressed":[{"type":"excepti \</\>

---

<div class="post-metadata">

**Author:** ![Mariusko82](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mariusko82/32/119046_2.png) [@Mariusko82](https://discuss.elastic.co/u/Mariusko82)\
**Post date:** [April 14, 2023, 12:43pm UTC](https://discuss.elastic.co/t/azure-snapshot-issue-getting-blob-storage-exception-reason-status-code-400-nblobtypenotsupportedblock-blobs-are-not-supported/328690/2 "2023-04-14T12:43:01Z")

</div>

So the issue was that I used wrong blob type. When I used :

account\_kind = "BlockBlobStorage"

it started to work.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 12, 2023, 12:43pm UTC](https://discuss.elastic.co/t/azure-snapshot-issue-getting-blob-storage-exception-reason-status-code-400-nblobtypenotsupportedblock-blobs-are-not-supported/328690/3 "2023-05-12T12:43:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
