# Bad Request error when creating a new Kibana index pattern

**URL:** <https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831>\
**Category:** Kibana\
**Created:** [June 26, 2020, 10:08am UTC](https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831 "2020-06-26T10:08:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mark\_Duncan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mark_duncan/32/46467_2.png) [@Mark\_Duncan](https://discuss.elastic.co/u/Mark_Duncan)\
**Post date:** [June 26, 2020, 10:08am UTC](https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831/1 "2020-06-26T10:08:08Z")

</div>

I am getting an error when trying to create a new Kibana index pattern:

`Error: Bad Request`

 ![Screenshot 2020-06-26 at 10.58.32](https://us1.discourse-cdn.com/elastic/original/3X/f/4/f425a50abeb2f10889769bc970c564ac473ddd5a.png)

I don't have any details about why it's not working. Any thoughts?

...

I did apply the following the other day - intending to add an ingest\_timestamp to all Elasticsearch indexes as per this article: [Dec 12th, 2018: [EN][Elasticsearch] Automatically adding a timestamp to documents](https://discuss.elastic.co/t/dec-12th-2018-en-elasticsearch-automatically-adding-a-timestamp-to-documents/159314)

Could this be causing issues?

```
PUT _ingest/pipeline/my_timestamp_pipeline
{
  "description": "Adds a field to a document with the time of ingestion into Elasticsearch",
  "processors": [
    {
      "set": {
        "field": "ingest_timestamp",
        "value": "{{_ingest.timestamp}}"
      }
    }
  ]
}

PUT /*/_settings
{
  "settings": {
    "default_pipeline": "my_timestamp_pipeline"
  }
}
```

---

<div class="post-metadata">

**Author:** ![Mark\_Duncan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mark_duncan/32/46467_2.png) [@Mark\_Duncan](https://discuss.elastic.co/u/Mark_Duncan)\
**Post date:** [June 26, 2020, 10:37am UTC](https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831/2 "2020-06-26T10:37:40Z")

</div>

I see this response in the network panel... seems there is some more work needed to set this up

```
{"message":"mapping set to strict, dynamic introduction of [ingest_timestamp] within [_doc] is not allowed: [strict_dynamic_mapping_exception] mapping set to strict, dynamic introduction of [ingest_timestamp] within [_doc] is not allowed","statusCode":400,"error":"Bad Request"}
```

---

<div class="post-metadata">

**Author:** ![Mark\_Duncan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mark_duncan/32/46467_2.png) [@Mark\_Duncan](https://discuss.elastic.co/u/Mark_Duncan)\
**Post date:** [June 26, 2020, 10:56am UTC](https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831/3 "2020-06-26T10:56:14Z")

</div>

seems I shouldn't have updated the .kibana\_\* indexes

> [@Kibana: mapping set to strict, dynamic introduction of \[references\] within \[doc\] is not allowed](https://discuss.elastic.co/t/kibana-mapping-set-to-strict-dynamic-introduction-of-references-within-doc-is-not-allowed/176403/2):
>
> Same issue here. Came from an elastic stack 6.7.1 and just updated to 7.0.0. Our stack runs in docker. Kibana has no additional config.

this solved it:

> PUT /.kibana\_\*/\_settings  
> {  
> "settings": {  
> "default\_pipeline": null  
> }  
> }

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 24, 2020, 10:56am UTC](https://discuss.elastic.co/t/bad-request-error-when-creating-a-new-kibana-index-pattern/238831/4 "2020-07-24T10:56:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
