# Bad Request in Dashboard for long time interval query

**URL:** <https://discuss.elastic.co/t/bad-request-in-dashboard-for-long-time-interval-query/271491>\
**Category:** Kibana\
**Created:** [April 28, 2021, 9:34am UTC](https://discuss.elastic.co/t/bad-request-in-dashboard-for-long-time-interval-query/271491 "2021-04-28T09:34:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Elaak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elaak/32/55014_2.png) [@Elaak](https://discuss.elastic.co/u/Elaak)\
**Post date:** [April 28, 2021, 9:34am UTC](https://discuss.elastic.co/t/bad-request-in-dashboard-for-long-time-interval-query/271491/1 "2021-04-28T09:34:58Z")

</div>

I am running Elastic Stack 7.9 and am having issues with my dashboard. When I try to catch all my data (search for last 1000 years) in my Kibana dashboard I get an error on the saved Discover table that I have included, but not for the visualizations. In the console for the developer tools I see an error `Failed to load resource: the server responded with a status of 400 (Bad Request)`, when I look into the logs I see that the request is for `POST /internal/search/es` but there is no further information.

It appears to work when I do the same in Discover, so what might be the cause of this error? I cannot access the elasticsearch logs at the moment. I have some formatter plugins active, such as converting some links to image previews. Could it be that the processing of the plugins and the huge amount of data is causing a server overload or something?

Why would this error only occur within a dashboard though, and not in Discover? Is the Discover Table in the Dashboard retrieving more data, or in a different way, than in Discover, for the exact same request (no filters, time 1000years - now)?

---

<div class="post-metadata">

**Author:** ![dosant](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dosant/32/64489_2.png) [@dosant](https://discuss.elastic.co/u/dosant)\
**Post date:** [April 28, 2021, 10:36am UTC](https://discuss.elastic.co/t/bad-request-in-dashboard-for-long-time-interval-query/271491/2 "2021-04-28T10:36:23Z")

</div>

Hi @Elaak,

> Is the Discover Table in the Dashboard retrieving more data, or in a different way than in Discover, for the exact same request (no filters, time 1000years - now)?

I'd check the request body of `POST /internal/search/es`.  
Are those different?  
Maybe there are some clues of what might have gone wrong here.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 28, 2021, 8:11am UTC](https://discuss.elastic.co/t/bad-request-in-dashboard-for-long-time-interval-query/271491/4 "2021-05-28T08:11:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
