# Bad request when generating CSV -\> HPE\_HEADER\_OVERFLOW

**URL:** https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831
**Category:** Kibana
**Created:** [December 21, 2018, 10:17am UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831 "2018-12-21T10:17:08Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Zzo](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zzo](https://discuss.elastic.co/u/Zzo)
#### Post date: [December 21, 2018, 10:17am UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/1 "2018-12-21T10:17:08Z")

</div>

Hi,

I'm running the basic edition of ES and Kibana 6.5.3.  
Since I moved from 6.5.0 to 6.5.3 I have some issue when generating CSV from the Discover.  
I have a popup with "Reporting error : Bad request".  
And in the kibana.log : {"type":"error","@timestamp":"2018-12-21T09:42:59Z","tags":["connection","client","error"],"pid":10376,"level":"error","error":{"message":"Parse Error","name":"Error","stack":"Error: Parse Error","code":"HPE\_HEADER\_OVERFLOW"},"message":"Parse Error"}

This happens when I add a specific computed field from the number/percentage format which calculate a security score for my assets stored in my assets index.  
How can I solve the issue so I can export in CSV just like when running 6.5.0?

Regards

---

<div class="post-metadata">

### Author: ![spalger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spalger/32/14092_2.png) [@spalger](https://discuss.elastic.co/u/spalger)
#### Post date: [December 22, 2018, 12:50am UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/2 "2018-12-22T00:50:31Z")

</div>

Kibana 6.5.3 upgraded to node.js 8.14.0, which has a fix for [CVE-2018-12121](https://nvd.nist.gov/vuln/detail/CVE-2018-12121). This imposes an 8k limit on the headers, which it would seem is what you've bumped into. I've created [https://github.com/elastic/kibana/issues/27724](https://github.com/elastic/kibana/issues/27724) which hopefully we can address after the holidays here in the US.

You might want to inspect the headers that your browser is sending to Kibana, if there is anything massive in there that might not be necessary (maybe a cookie injected by a proxy or something) you might be able to get rid of it and get things working.

---

<div class="post-metadata">

### Author: ![Alberto\_Yoldi](https://avatars.discourse-cdn.com/v4/letter/a/b782af/32.png) [@Alberto\_Yoldi](https://discuss.elastic.co/u/Alberto_Yoldi)
#### Post date: [December 31, 2018, 9:18am UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/3 "2018-12-31T09:18:46Z")

</div>

We are also facing the same issue as there is an Apache server infront that performs the Kerberos authentication. I hope it can be solved soon, as its critical for us and is a clear stopper for taking the upgrade to production ☹

Thanks @Zzo for reporting and @spalger for taking care!

Regards,

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [January 4, 2019, 7:50pm UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/4 "2019-01-04T19:50:46Z")

</div>

@Alberto_Yoldi are you only seeing this limit reached for the Kerberos authentication? Do you know the header size it requires?

---

<div class="post-metadata">

### Author: ![Zzo](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zzo](https://discuss.elastic.co/u/Zzo)
#### Post date: [January 7, 2019, 11:27am UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/5 "2019-01-07T11:27:46Z")

</div>

Thank you and sorry for the late reply due to holidays.  
I have rolled back to 6.4.3 and now it's working fine again.  
I think my scripted fields are way to heavy for the 8K limit.  
How can I check the size of the headers?

---

<div class="post-metadata">

### Author: ![Ram\_Varra](https://avatars.discourse-cdn.com/v4/letter/r/65b543/32.png) [@Ram\_Varra](https://discuss.elastic.co/u/Ram_Varra)
#### Post date: [January 22, 2019, 5:00pm UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/6 "2019-01-22T17:00:49Z")

</div>

I am seeing the same issue with with 6.5.4 Version. The Kibana logs reporting parse errors with code; 'HPE\_HEADER\_OVERFLOW' most of the time. Is there any plan to address this soon or should we downgrade to 6.4.3 for now?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 19, 2019, 5:00pm UTC](https://discuss.elastic.co/t/bad-request-when-generating-csv-hpe-header-overflow/161831/7 "2019-02-19T17:00:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
