# Beats error: No paths were defined for input accessing config

**URL:** https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285
**Category:** Beats
**Tags:** beats-module, filebeat
**Created:** [April 19, 2023, 9:17am UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285 "2023-04-19T09:17:30Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Skairik](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@Skairik](https://discuss.elastic.co/u/Skairik)
#### Post date: [April 19, 2023, 9:17am UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285/1 "2023-04-19T09:17:30Z")

</div>

Hi everyone ,

I am currently trying to configure filebeat to retrieve logs from my palo alto firewall, I have configured and enable the panw modules:

```auto
- module: panw
  panos:
    enabled: true
    var.input: udp
    var.syslog_host: 0.0.0.0
    var.syslog_host: 9001

```

And my filebeat.yml configuration:

```auto
filebeat.inputs:
- type: log
  id: my-filestream-id
  enabled: true
  paths:
   - /var/log/*.log
filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true
setup.template.settings:
  index.number_of_shards: 1
setup.kibana:
  host: "172.16.10.62:5601"
output.elasticsearch:
  hosts: ["localhost:9200"]
  protocol: "https"
  username: "elastic"
  password: "ozPpuZ0=ypPMUHJLkobf"
  ssl:
    enabled: true
    ca_trusted_fingerprint: "051670d7e5518a12a0d63ab9c84ce6bc2313371b9a5e6d55b0e4276804eedab2"
processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

```

And there is the error i got:

```auto
Apr 19 09:12:11 srv-elk filebeat[1363719]: {"log.level":"error","@timestamp":"2023-04-19T09:12:11.648Z","log.logger":"reload","log.origin":{"fi le.name":"cfgfile/list.go","file.line":109},"message":"Error creating runner from config: failed to create input: No paths were defined for input accessing config","service.name":"filebeat","ecs.version":"1.6.0"}

```

I'm just starting with filebeat but if I understand correctly I don't need to set anything in filebeats.yml if i use a module right?

If anyone has an idea .. 😄

---

<div class="post-metadata">

### Author: ![Skairik](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@Skairik](https://discuss.elastic.co/u/Skairik)
#### Post date: [April 21, 2023, 12:54pm UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285/2 "2023-04-21T12:54:59Z")

</div>

It seems that he necessarily wants a path, as if he necessarily wants me to install filebeats on the firewall. Yet I saw that it was possible to install this module in this way.

I tried a similar configuration with the fortinet module and listening on the port activates well.

Any ideas ?

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [April 23, 2023, 3:20pm UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285/3 "2023-04-23T15:20:06Z")

</div>

This can happen if you have enabled inputs or modules but not added paths.

Please run

`filebeat modules list

Also, is that the entire `panw.yml`

Also do you purposely have that filestream enabled

---

<div class="post-metadata">

### Author: ![Skairik](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@Skairik](https://discuss.elastic.co/u/Skairik)
#### Post date: [April 24, 2023, 7:36am UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285/4 "2023-04-24T07:36:47Z")

</div>

Thanks for the reply,  
Here is the command, there is only this module activated:

```auto
root@srv-elk:/home/tml# filebeat modules list
Enabled:
panw

Disabled:
activemq
...

```

And yes i sent the whole file.  
For the filebeat.inputs, I forgot it, I disabled it but nothing changes.  
But i saw something in the panw.yml, there was this comment sentence above the var.input:

```auto
# Set which input to use between syslog (default) or file.

```

I thought that since I was using udp to send my logs, I need to set udp for the input but I guess no  
**So i set the input to syslog**  
My panw.yml:

```auto

- module: panw
  panos:
    enabled: true
    # Set which input to use between syslog (default) or file.
    var.input: syslog
    #var.paths: ["/var/log/pan-os.log"]
    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.syslog_host: 0.0.0.0
    var.syslog_host: 9001

```

So i guess the original **error is solved.**  
But now, i got an another error:

```auto
Apr 24 06:43:32 srv-elk filebeat[1407097]: {"log.level":"error","@timestamp":"2023-04-24T06:43:32.198Z","log.logger":"syslog","log.origin":"file.name":"syslog/input.go","file.line":151},"message":"Error starting the servererrorlisten udp 0.0.35.41:9001: bind: cannot assign requested address","service.name":"filebeat","ecs.version":"1.6.0"}

```

**I just realized that I put 2 times var.syslog\_host, instead of port...**  
Now listening goes without any errors.

So the original error was because of the **input type.**

My final panw.yml:

```auto
type or paste code here- module: panw
  panos:
    enabled: true

    # Set which input to use between syslog (default) or file.
    var.input: syslog
    #var.paths: ["/var/log/pan-os.log"]
    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.syslog_host: 0.0.0.0
    var.syslog_port: 9001

    # Set internal security zones. used to determine network.direction
    # default "trust"
    #var.internal_zones:

    # Set external security zones. used to determine network.direction
    # default "untrust"
    #var.external_zones:

```

All this could have been avoided if I had opened my eyes properly. 🫣

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 22, 2023, 9:37am UTC](https://discuss.elastic.co/t/beats-error-no-paths-were-defined-for-input-accessing-config/330285/5 "2023-05-22T09:37:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
