# Beats plugin configuation

**URL:** <https://discuss.elastic.co/t/beats-plugin-configuation/36867>\
**Category:** Logstash\
**Created:** [December 10, 2015, 10:58am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867 "2015-12-10T10:58:08Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Max\_Just](https://avatars.discourse-cdn.com/v4/letter/m/e79b87/32.png) [@Max\_Just](https://discuss.elastic.co/u/Max_Just)\
**Post date:** [December 10, 2015, 10:58am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/1 "2015-12-10T10:58:08Z")

</div>

is it possible to set ports as a range or array in logstash config

instead  
beats {  
port =\> 5013  
ssl =\> true  
ssl\_certificate =\> "/etc/pki/tls/certs/logstash-forwarder.crt"  
ssl\_key =\> "/etc/pki/tls/private/logstash-forwarder.key"  
}  
.....  
beats {  
port =\> 5030  
ssl =\> true  
ssl\_certificate =\> "/etc/pki/tls/certs/logstash-forwarder.crt"  
ssl\_key =\> "/etc/pki/tls/private/logstash-forwarder.key"  
}

some thing like 5013-5030

---

<div class="post-metadata">

**Author:** ![rclarke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rclarke/32/68604_2.png) [@rclarke](https://discuss.elastic.co/u/rclarke)\
**Post date:** [December 10, 2015, 11:02am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/2 "2015-12-10T11:02:53Z")

</div>

Hello Max,

The port configuration must be a single value.  
Can you explain why you would need it to listen on multiple ports?

Cheers,  
-Robin-

---

<div class="post-metadata">

**Author:** ![Max\_Just](https://avatars.discourse-cdn.com/v4/letter/m/e79b87/32.png) [@Max\_Just](https://discuss.elastic.co/u/Max_Just)\
**Post date:** [December 10, 2015, 11:07am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/3 "2015-12-10T11:07:03Z")

</div>

I have a lot of remoted hosts, as I understood, I can`t connect remote few host to one local port (to logstash). And what why I need create a batch of records. I have about a 30 hosts. so =\> 30 batch in config like:

> [@Max\_Just](#):
>
> beats { port =\> 5030 ssl =\> true ssl\_certificate =\> "/etc/pki/tls/certs/logstash-forwarder.crt" ssl\_key =\> "/etc/pki/tls/private/logstash-forwarder.key" }

it is a realy hard to use and read, whats why I looking another wy to centralize the logs.

---

<div class="post-metadata">

**Author:** ![rclarke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rclarke/32/68604_2.png) [@rclarke](https://discuss.elastic.co/u/rclarke)\
**Post date:** [December 10, 2015, 11:13am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/4 "2015-12-10T11:13:44Z")

</div>

Hello Max,

Yes - you _can_ connect many beats sources to one beats input port in logstash - this is the best way to do it. 🙂

Cheers,  
-Robin-

---

<div class="post-metadata">

**Author:** ![Max\_Just](https://avatars.discourse-cdn.com/v4/letter/m/e79b87/32.png) [@Max\_Just](https://discuss.elastic.co/u/Max_Just)\
**Post date:** [December 10, 2015, 11:21am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/5 "2015-12-10T11:21:16Z")

</div>

hm.., now it works fine, but when I try to do it some time ago I got this errors:

Dec 10 11:10:00 broker1 /usr/bin/filebeat[22270]: transport.go:125: SSL client failed to connect with: EOF  
Dec 10 11:10:39 broker1 /usr/bin/filebeat[22270]: message repeated 22 times: [transport.go:125: SSL client failed to connect with: EOF]  
Dec 10 11:10:41 broker1 /usr/bin/filebeat[22270]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.201:5044: getsockopt: connection refused

but now it really was started... thnx for your reply.

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [December 10, 2015, 11:36am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/6 "2015-12-10T11:36:05Z")

</div>

Well, nothing was listening on port 5044 at the time. Perhaps Logstash was down or there was a typo in a configuration file somewhere or a firewall was blocking the connection attempts.

---

<div class="post-metadata">

**Author:** ![Max\_Just](https://avatars.discourse-cdn.com/v4/letter/m/e79b87/32.png) [@Max\_Just](https://discuss.elastic.co/u/Max_Just)\
**Post date:** [December 10, 2015, 11:38am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/7 "2015-12-10T11:38:51Z")

</div>

most likely, it confused me. now all works fine, thnx.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:19am UTC](https://discuss.elastic.co/t/beats-plugin-configuation/36867/8 "2017-07-06T05:19:07Z")

</div>


