# Beats to Logstash pipeline - Self signed cert implementation

**URL:** <https://discuss.elastic.co/t/beats-to-logstash-pipeline-self-signed-cert-implementation/311090>\
**Category:** Beats\
**Tags:** elastic-stack-security, filebeat\
**Created:** [August 1, 2022, 8:09am UTC](https://discuss.elastic.co/t/beats-to-logstash-pipeline-self-signed-cert-implementation/311090 "2022-08-01T08:09:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sravan\_kaheti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sravan_kaheti/32/133184_2.png) [@sravan\_kaheti](https://discuss.elastic.co/u/sravan_kaheti)\
**Post date:** [August 1, 2022, 8:09am UTC](https://discuss.elastic.co/t/beats-to-logstash-pipeline-self-signed-cert-implementation/311090/1 "2022-08-01T08:09:08Z")

</div>

Hi There ,

I am using filebeat, metricbeat and passing output to my logstash pipeline (version 8.1). I have a requirement that need to implement self signed cert to secure communication between beats to our logstash.

But getting error like follows  
ERROR [publisher\_pipeline\_output] pipeline/output.go:154 Failed to connect to backoff(async(tcp://XX.XXX.XX.XX:5064)): x509: certificate signed by unknown authority

Please help me on bypass this error

---

<div class="post-metadata">

**Author:** ![TiagoQueiroz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tiagoqueiroz/32/107061_2.png) [@TiagoQueiroz](https://discuss.elastic.co/u/TiagoQueiroz)\
**Post date:** [August 1, 2022, 10:32am UTC](https://discuss.elastic.co/t/beats-to-logstash-pipeline-self-signed-cert-implementation/311090/2 "2022-08-01T10:32:45Z")

</div>

You need to set the SSL options on Beats so they trust the self-signed certificate, you can find the details on our documentation: [Configure the Logstash output | Filebeat Reference [8.3] | Elastic](https://www.elastic.co/guide/en/beats/filebeat/current/logstash-output.html#_ssl_4)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2022, 12:32pm UTC](https://discuss.elastic.co/t/beats-to-logstash-pipeline-self-signed-cert-implementation/311090/3 "2022-08-29T12:32:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
