# 障害時のBeats動作について教えてください

**URL:** https://discuss.elastic.co/t/beats/113133
**Category:** 日本語による質問・議論はこちら
**Created:** [December 25, 2017, 8:10am UTC](https://discuss.elastic.co/t/beats/113133 "2017-12-25T08:10:27Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![shingo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shingo/32/25960_2.png) [@shingo](https://discuss.elastic.co/u/shingo)
#### Post date: [December 25, 2017, 8:10am UTC](https://discuss.elastic.co/t/beats/113133/1 "2017-12-25T08:10:27Z")

</div>

みなさま、はじめまして。最近Elasticデビューしました。  
初投稿となりますので、至らない点がございましたらご容赦ください。

\<環境\>  
・Elastic Server (以降、ES) 6.x  
・Beats (Metric、File、Packet） 6.1  
・Ubuntu 16.04.2 Server（ES、Beats双方とも)  
[ES] \<------- [Beats]

\<質問\>  
・ESサーバ障害時やネットワーク障害など、BeatsからESへの通信が途絶した場合、  
Beatsによって収集されたMetricデータは障害復旧後に自動的に送信されますか？

・障害時、Beatsがローカルにデータを保管する期限や場所、容量等の指定は可能でしょうか？

・これらが記載されたドキュメントを見つけられませんでした。  
ご存知のかた、いらっしゃいましたらご教授願います。（英語でも可）

---

<div class="post-metadata">

### Author: ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)
#### Post date: [December 25, 2017, 3:57pm UTC](https://discuss.elastic.co/t/beats/113133/2 "2017-12-25T15:57:27Z")

</div>

- ESサーバ障害時やネットワーク障害など、BeatsからESへの通信が途絶した場合、  
Beatsによって収集されたMetricデータは障害復旧後に自動的に送信されますか？

送信に失敗したときはリトライする設定がbeatsにはあるので、たとえばmetricbeatですとESへの通信が途絶し、  
復旧したら、max\_retriesによって自動的に送信されるようです。

これは、こんな感じで動作確認できるかと思います。

## 確認手順

1. ESを起動
2. metricbeatの起動 (max\_retries: 30 )
3. ESを停止
4. 1分待つ
5. ESを起動
6. 4で停止していた時間内もデータが登録されてることをKibanaで確認

max\_retriesについては、こちらに記載がありました。

> **[Configure the Elasticsearch output | Beats](https://www.elastic.co/docs/reference/beats/filebeat/elasticsearch-output)**
>
> The Elasticsearch output sends events directly to Elasticsearch using the Elasticsearch HTTP API. Example configuration: When sending data to a secured...

- 障害時、Beatsがローカルにデータを保管する期限や場所、容量等の指定は可能でしょうか？

送信途中に落ちてしまったときのためにディスクにキューを書いておく、というPersistent queuesがLogstashにはありますが、  
beatsが障害発生時にローカルファイルにデータを書き出す、という内容については私も探せませんでした。  
discuss内の他の投稿で、githubからforkして作ってみるよ、という方はいらっしゃいましたが、公式にファイルに書き出す、というものは見当たりませんでした。

> [@How to Handle Publication Failures](https://discuss.elastic.co/t/how-to-handle-publication-failures/38753):
>
> I'm writing a Beat to pull events from a message queue and publish them via libbeat. If an event fails to publish, I'd like to send it to a dead letter queue. However, from looking at the outputs/elasticsearch/client.go#PublishEvent implementation, I get the impression that publication failure isn't always communicated back to the beat. Can anyone suggest the right approach for detecting and handling failures? My ultimate goal is to ensure that event data is never lost.

可用性やスケールを考慮した場合、どういう配置にするかといった点では、以下のページが参考になるかと思います。

> **[Deploying and scaling Logstash | Logstash](https://www.elastic.co/docs/reference/logstash/deploying-scaling-logstash)**
>
> The Elastic Stack is used for a great variety of use cases, from operational log and metrics analytics, to enterprise and application search. Making sure...

---

<div class="post-metadata">

### Author: ![shingo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shingo/32/25960_2.png) [@shingo](https://discuss.elastic.co/u/shingo)
#### Post date: [January 10, 2018, 1:35am UTC](https://discuss.elastic.co/t/beats/113133/3 "2018-01-10T01:35:31Z")

</div>

tsgkdtさま

返信が遅くなり大変申し訳ありません。

確認手順まで用意いただき感謝いたします。  
提示いただいたリンク内容を確認し、max\_retriesについて理解が深まりました。  
beatsが起動さえしていれば、max\_retriesに基づいて良しなに再送してくれることも確認できました。  
一部Filebeatなどはmax\_retriesの設定が無視されるとの記載も。

今後、可用性やスケールについて検討したいと思います。  
ありがとうございました。

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 7, 2018, 1:35am UTC](https://discuss.elastic.co/t/beats/113133/4 "2018-02-07T01:35:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
