# BindTransportException\[Failed to bind to \[9300-9400\]\]; nested: BindException\[Cannot assign requested address

**URL:** <https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048>\
**Category:** Elasticsearch\
**Created:** [May 16, 2018, 7:17am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048 "2018-05-16T07:17:14Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sahara](https://avatars.discourse-cdn.com/v4/letter/s/9e8a1a/32.png) [@sahara](https://discuss.elastic.co/u/sahara)\
**Post date:** [May 16, 2018, 7:17am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048/1 "2018-05-16T07:17:14Z")

</div>

elasticsearch.yml

network.host: 10.42.0.204  
http.port: 9200

my host has address 10.1.1.209

my stack trace

[2018-05-16T12:44:35,056][INFO][o.e.n.Node] [2VhkBLX] starting ...  
[2018-05-16T12:44:35,216][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to bind to [9300-9400]]; nested: BindException[Cannot assign requested address];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) ~[elasticsearch-6.2.4.jar:6.2.4]  
Caused by: org.elasticsearch.transport.BindTransportException: Failed to bind to [9300-9400]  
at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:794) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:759) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:135) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:66) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:213) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:66) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.node.Node.start(Node.java:623) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:262) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:332) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-6.2.4.jar:6.2.4]  
... 6 more  
Caused by: java.net.BindException: Cannot assign requested address  
at sun.nio.ch.Net.bind0(Native Method) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:433) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:425) ~[?:?]  
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) ~[?:?]  
at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:128) ~[?:?]  
at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:558) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1283) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:501) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:486) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:989) ~[?:?]  
at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:254) ~[?:?]  
at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:365) ~[?:?]  
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:403) ~[?:?]  
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:463) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) ~[?:?]  
at java.lang.Thread.run(Thread.java:748) [?:1.8.0\_171]  
[2018-05-16T12:44:36,074][INFO][o.e.n.Node] [2VhkBLX] stopping ...  
[2018-05-16T12:44:36,078][INFO][o.e.n.Node] [2VhkBLX] stopped  
[2018-05-16T12:44:36,079][INFO][o.e.n.Node] [2VhkBLX] closing ...  
[2018-05-16T12:44:36,084][INFO][o.e.n.Node] [2VhkBLX] closed

---

<div class="post-metadata">

**Author:** ![sunil\_sunny](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@sunil\_sunny](https://discuss.elastic.co/u/sunil_sunny)\
**Post date:** [May 31, 2018, 2:00pm UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048/2 "2018-05-31T14:00:57Z")

</div>

Did you get any solution, I am facing the same problem

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [May 31, 2018, 2:16pm UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048/3 "2018-05-31T14:16:07Z")

</div>

Hi,

The error is quite clear, you are trying to assign a ip that is not configured on your box.

In this example you configure  
network.host: 10.42.0.204  
http.port: 9200

But your box has  
my host has address 10.1.1.209

That is not correct, the elasticsearch.yml should reflect your network. ie:  
network.host: 10.1.1.209

---

<div class="post-metadata">

**Author:** ![sahara](https://avatars.discourse-cdn.com/v4/letter/s/9e8a1a/32.png) [@sahara](https://discuss.elastic.co/u/sahara)\
**Post date:** [June 4, 2018, 7:15am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048/4 "2018-06-04T07:15:55Z")

</div>

I found solution like this  
#http communication  
network.bind\_host: 10.1.1.209  
http.port: 9200  
#node communication  
node.master: true  
node.data: true  
transport.host: localhost  
transport.tcp.port: 9300

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 2, 2018, 7:15am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400-nested-bindexception-cannot-assign-requested-address/132048/5 "2018-07-02T07:15:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
