# BindTransportException\[Failed to bind to \[9300-9400\]\]

**URL:** <https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443>\
**Category:** Elasticsearch\
**Created:** [November 9, 2016, 7:38am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443 "2016-11-09T07:38:22Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Srini12](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@Srini12](https://discuss.elastic.co/u/Srini12)\
**Post date:** [November 9, 2016, 7:38am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/1 "2016-11-09T07:38:22Z")

</div>

Good day  
I am using VM to run elastic search 2.3.3  
i have changed only following to elasticsearch.yml file

**network.host: [xx.xx.xx.xxx](http://xx.xx.xx.xxx)**

\*\* http.port: 9200\*\*

i have opened the port for inboud and out bound rules.

i have installed the service, when i am running i am getting following error:

BindTransportException[Failed to bind to [9300-9400]]; nested: ChannelException[Failed to bind to: /xx.xx.xx.xx:9400]; nested: BindException[Cannot assign requested address: bind];  
at org.elasticsearch.transport.netty.NettyTransport.bindToPort(NettyTransport.java:478)  
at org.elasticsearch.transport.netty.NettyTransport.bindServerBootstrap(NettyTransport.java:440)  
at org.elasticsearch.transport.netty.NettyTransport.doStart(NettyTransport.java:321)  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:68)  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:182)  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:68)  
at org.elasticsearch.node.Node.start(Node.java:278)  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:206)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:272)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Caused by: org.jboss.netty.channel.ChannelException: Failed to bind to: /40.69.33.112:9400  
at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:272)  
at org.elasticsearch.transport.netty.NettyTransport$1.onPortNumber(NettyTransport.java:460)  
at org.elasticsearch.common.transport.PortsRange.iterate(PortsRange.java:69)  
at org.elasticsearch.transport.netty.NettyTransport.bindToPort(NettyTransport.java:456)  
... 9 more

any help in this regard appreciated.  
one more thing: we are running Solr on the same VM

---

<div class="post-metadata">

**Author:** ![Srini12](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@Srini12](https://discuss.elastic.co/u/Srini12)\
**Post date:** [November 9, 2016, 8:33am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/2 "2016-11-09T08:33:58Z")

</div>

UPDATE : replacing network host value with : 0.0.0.0  
worked for now.. can any one explain the threats or issues for opening it all IPs

---

<div class="post-metadata">

**Author:** ![ywelsch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ywelsch/32/7751_2.png) [@ywelsch](https://discuss.elastic.co/u/ywelsch)\
**Post date:** [November 9, 2016, 8:36am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/3 "2016-11-09T08:36:07Z")

</div>

From the [Javadocs](https://docs.oracle.com/javase/7/docs/api/java/net/BindException.html):

> Signals that an error occurred while attempting to bind a socket to a local address and port. Typically, the port is in use, or the requested local address could not be assigned.

Is it possible that you misconfigured `network.host` to an IP address that does not exist on any of your network interfaces? Maybe use one of the [special values](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/modules-network.html#network-interface-values) instead of going for an explicit value.

---

<div class="post-metadata">

**Author:** ![Srini12](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@Srini12](https://discuss.elastic.co/u/Srini12)\
**Post date:** [November 9, 2016, 8:40am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/4 "2016-11-09T08:40:05Z")

</div>

> [@ywelsch](#):
>
> ssible that you misconfigured n

Hi, thanks for reply  
No, i have double checked it.. ip is correct and more over Solr search is accessible with the same ip (We have both searches on the same VM.).

---

<div class="post-metadata">

**Author:** ![ywelsch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ywelsch/32/7751_2.png) [@ywelsch](https://discuss.elastic.co/u/ywelsch)\
**Post date:** [November 9, 2016, 8:49am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/5 "2016-11-09T08:49:24Z")

</div>

The IP address (which is still visible in the stacktrace of your original post) is a public IP and probably not one available on your network interfaces in the VM. To see which ones are available (after you've configured 0.0.0.0) have a look at the bound\_addresses that appear in the ES log output.

---

<div class="post-metadata">

**Author:** ![Srini12](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@Srini12](https://discuss.elastic.co/u/Srini12)\
**Post date:** [November 9, 2016, 9:05am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/6 "2016-11-09T09:05:41Z")

</div>

Hi, below is the log which is showing 10.0.0.4:9300 as publish address..  
after changing it to 0.0.0.0 (pls ignore time stamp)

thanks in advance

[2016-11-09 08:18:00,989][INFO][node] [Peter Parker] initializing ...  
[2016-11-09 08:18:01,692][INFO][plugins] [Peter Parker] modules [reindex, lang-expression, lang-groovy], plugins [head, analysis-phonetic], sites [head]  
[2016-11-09 08:18:01,723][INFO][env] [Peter Parker] using [1] data paths, mounts [[(C:)]], net usable\_space [54.7gb], net total\_space [126.9gb], spins? [unknown], types [NTFS]  
[2016-11-09 08:18:01,723][INFO][env] [Peter Parker] heap size [989.8mb], compressed ordinary object pointers [unknown]  
[2016-11-09 08:18:03,395][INFO][node] [Peter Parker] initialized  
[2016-11-09 08:18:03,395][INFO][node] [Peter Parker] starting ...  
[2016-11-09 08:18:03,551][INFO][transport] [Peter Parker] publish\_address {10.0.0.4:9300}, bound\_addresses {[::]:9300}  
[2016-11-09 08:18:03,551][INFO][discovery] [Peter Parker] sapnet/K-jWzo3VS5C\_TYaWWeY\_tw  
[2016-11-09 08:18:07,598][INFO][cluster.service] [Peter Parker] new\_master {Peter Parker}{K-jWzo3VS5C\_TYaWWeY\_tw}{10.0.0.4}{10.0.0.4:9300}, reason: zen-disco-join(elected\_as\_master, [0] joins received)  
[2016-11-09 08:18:07,707][INFO][gateway] [Peter Parker] recovered [0] indices into cluster\_state  
[2016-11-09 08:18:07,723][INFO][http] [Peter Parker] publish\_address {10.0.0.4:9200}, bound\_addresses {[::]:9200}  
[2016-11-09 08:18:07,723][INFO][node] [Peter Parker] started

---

<div class="post-metadata">

**Author:** ![ywelsch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ywelsch/32/7751_2.png) [@ywelsch](https://discuss.elastic.co/u/ywelsch)\
**Post date:** [November 9, 2016, 9:12am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/7 "2016-11-09T09:12:00Z")

</div>

So that's your answer then (use 10.0.0.4). If that address is dynamically assigned (e.g. when VM is restarted) you can also use one of the [special values](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/modules-network.html#network-interface-values) which allow you for example to bind to an addresses of a specific network interface, for example _en0_.

---

<div class="post-metadata">

**Author:** ![Srini12](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@Srini12](https://discuss.elastic.co/u/Srini12)\
**Post date:** [November 9, 2016, 9:21am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/8 "2016-11-09T09:21:41Z")

</div>

Hi  
If i use : 10.0.0.4, i can't access outside the vm, it works when i am browsing inside VM.  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 7, 2016, 9:21am UTC](https://discuss.elastic.co/t/bindtransportexception-failed-to-bind-to-9300-9400/65443/9 "2016-12-07T09:21:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
