# \`block in start\_input\` appears when trying to run logstash input using jdbc plugin

**URL:** https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697
**Category:** Logstash
**Tags:** jdbc
**Created:** [September 5, 2022, 3:37pm UTC](https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697 "2022-09-05T15:37:21Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Khammassi\_HoussemEdd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khammassi_houssemedd/32/101568_2.png) [@Khammassi\_HoussemEdd](https://discuss.elastic.co/u/Khammassi_HoussemEdd)
#### Post date: [September 5, 2022, 3:37pm UTC](https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697/1 "2022-09-05T15:37:21Z")

</div>

Hello i have a mysql database and i want to ingest it's data into elasticsearch using logstash

after configuring the input and output i am getting the following error:

```auto
org/jruby/RubyArray.java:1865:in `each'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:54:in `load_driver_jars'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:34:in `load_driver'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/inputs/jdbc.rb:320:in `run'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:410:in `inputworker'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:401:in `block in start_input'
[ERROR] 2022-09-05 15:34:09.771 [[main]<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.
  Pipeline_id:main
  Plugin: <LogStash::Inputs::Jdbc jdbc_user=>"houssem", tracking_column=>"unix_ts_in_secs", use_column_value=>true, schedule=>"*/5 * * * * *", jdbc_paging_enabled=>true, jdbc_password=><password>, statement=>"SELECT * FROM log_cdr_2022_07_09", tracking_column_type=>"numeric", jdbc_driver_library=>"mysql-connector-java-8.0.30.jar", jdbc_connection_string=>"jdbc:mysql://localhost:3306/logsql", id=>"64b64830b6afe551dca20bfc82cacb431d3c065672d38f53bac902ea2aac02a5", jdbc_driver_class=>"com.mysql.jdbc.Driver", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_5d2c9893-d646-4d46-b898-ec28b48a336b", enable_metric=>true, charset=>"UTF-8">, jdbc_paging_mode=>"auto", jdbc_page_size=>100000, jdbc_validate_connection=>false, jdbc_validation_timeout=>3600, jdbc_pool_timeout=>5, sql_log_level=>"info", connection_retry_attempts=>1, connection_retry_attempts_wait_time=>0.5, plugin_timezone=>"utc", clean_run=>false, record_last_run=>true, lowercase_column_names=>true, use_prepared_statements=>false>
  Error: unable to load mysql-connector-java-8.0.30.jar from :jdbc_driver_library, no such file to load -- mysql-connector-java-8.0.30.jar
  Exception: LogStash::PluginLoadingError
  Stack: /usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:65:in `block in load_driver_jars'
org/jruby/RubyArray.java:1865:in `each'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:54:in `load_driver_jars'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:34:in `load_driver'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/inputs/jdbc.rb:320:in `run'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:410:in `inputworker'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:401:in `block in start_input'
[ERROR] 2022-09-05 15:34:10.783 [[main]<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.
  Pipeline_id:main
  Plugin: <LogStash::Inputs::Jdbc jdbc_user=>"houssem", tracking_column=>"unix_ts_in_secs", use_column_value=>true, schedule=>"*/5 * * * * *", jdbc_paging_enabled=>true, jdbc_password=><password>, statement=>"SELECT * FROM log_cdr_2022_07_09", tracking_column_type=>"numeric", jdbc_driver_library=>"mysql-connector-java-8.0.30.jar", jdbc_connection_string=>"jdbc:mysql://localhost:3306/logsql", id=>"64b64830b6afe551dca20bfc82cacb431d3c065672d38f53bac902ea2aac02a5", jdbc_driver_class=>"com.mysql.jdbc.Driver", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_5d2c9893-d646-4d46-b898-ec28b48a336b", enable_metric=>true, charset=>"UTF-8">, jdbc_paging_mode=>"auto", jdbc_page_size=>100000, jdbc_validate_connection=>false, jdbc_validation_timeout=>3600, jdbc_pool_timeout=>5, sql_log_level=>"info", connection_retry_attempts=>1, connection_retry_attempts_wait_time=>0.5, plugin_timezone=>"utc", clean_run=>false, record_last_run=>true, lowercase_column_names=>true, use_prepared_statements=>false>
  Error: unable to load mysql-connector-java-8.0.30.jar from :jdbc_driver_library, no such file to load -- mysql-connector-java-8.0.30.jar
  Exception: LogStash::PluginLoadingError
  Stack: /usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:65:in `block in load_driver_jars'
org/jruby/RubyArray.java:1865:in `each'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:54:in `load_driver_jars'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:34:in `load_driver'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/inputs/jdbc.rb:320:in `run'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:410:in `inputworker'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:401:in `block in start_input'
[ERROR] 2022-09-05 15:34:11.798 [[main]<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.
  Pipeline_id:main
  Plugin: <LogStash::Inputs::Jdbc jdbc_user=>"houssem", tracking_column=>"unix_ts_in_secs", use_column_value=>true, schedule=>"*/5 * * * * *", jdbc_paging_enabled=>true, jdbc_password=><password>, statement=>"SELECT * FROM log_cdr_2022_07_09", tracking_column_type=>"numeric", jdbc_driver_library=>"mysql-connector-java-8.0.30.jar", jdbc_connection_string=>"jdbc:mysql://localhost:3306/logsql", id=>"64b64830b6afe551dca20bfc82cacb431d3c065672d38f53bac902ea2aac02a5", jdbc_driver_class=>"com.mysql.jdbc.Driver", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_5d2c9893-d646-4d46-b898-ec28b48a336b", enable_metric=>true, charset=>"UTF-8">, jdbc_paging_mode=>"auto", jdbc_page_size=>100000, jdbc_validate_connection=>false, jdbc_validation_timeout=>3600, jdbc_pool_timeout=>5, sql_log_level=>"info", connection_retry_attempts=>1, connection_retry_attempts_wait_time=>0.5, plugin_timezone=>"utc", clean_run=>false, record_last_run=>true, lowercase_column_names=>true, use_prepared_statements=>false>
  Error: unable to load mysql-connector-java-8.0.30.jar from :jdbc_driver_library, no such file to load -- mysql-connector-java-8.0.30.jar
  Exception: LogStash::PluginLoadingError
  Stack: /usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:65:in `block in load_driver_jars'
org/jruby/RubyArray.java:1865:in `each'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:54:in `load_driver_jars'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/plugin_mixins/jdbc/common.rb:34:in `load_driver'
/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/logstash-integration-jdbc-5.3.0/lib/logstash/inputs/jdbc.rb:320:in `run'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:410:in `inputworker'
/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:401:in `block in start_input'

```

Following is my config file called jdbc.conf:

```auto
input {
  jdbc {
    jdbc_driver_library => "/etc/logstash/usr/share/java/mysql-connector-java-8.0.30.jar"
    jdbc_driver_class => "com.mysql.jdbc.Driver"
    jdbc_connection_string => "jdbc:mysql://localhost:3306/logsql"
    jdbc_user => "houssem"
    jdbc_password => "Oypoyp@202"
    statement => "SELECT * from CONFIG_CUSTOMER"
  }
}

output{
  file {
   path => "/etc/logstash/new_data.txt"
  }
}
~                                                                              
~                                                                              

```

and i run this command to start the pipeline:

```auto
sudo /usr/share/logstash/bin/logstash -f jdbc.conf

```

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [September 5, 2022, 4:45pm UTC](https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697/2 "2022-09-05T16:45:09Z")

</div>

Is this path correct?

```auto
 jdbc_driver_library => "/etc/logstash/usr/share/java/mysql-connector-java-8.0.30.jar"

```

Your log error says that it cannont find this file in the specified path.

> Error: unable to load mysql-connector-java-8.0.30.jar from :jdbc\_driver\_library, **no such file to load** -- mysql-connector-java-8.0.30.jar

---

<div class="post-metadata">

### Author: ![Khammassi\_HoussemEdd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khammassi_houssemedd/32/101568_2.png) [@Khammassi\_HoussemEdd](https://discuss.elastic.co/u/Khammassi_HoussemEdd)
#### Post date: [September 6, 2022, 7:49am UTC](https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697/3 "2022-09-06T07:49:09Z")

</div>

Hello @leandrojmp,  
yes the path is correct  
here it is :

![imagen](https://us1.discourse-cdn.com/elastic/original/3X/d/b/db30706bb22aea38a1640ff45a128d34a8ce0560.png)  
the following images shows that that path is correct

do you have any idea why he might says **no such file to load** while the path is correct

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 4, 2022, 7:49am UTC](https://discuss.elastic.co/t/block-in-start-input-appears-when-trying-to-run-logstash-input-using-jdbc-plugin/313697/4 "2022-10-04T07:49:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
