# Block in start-input (file not readable) sqlserver logstash

**URL:** <https://discuss.elastic.co/t/block-in-start-input-file-not-readable-sqlserver-logstash/307391>\
**Category:** Logstash\
**Created:** [June 16, 2022, 11:04am UTC](https://discuss.elastic.co/t/block-in-start-input-file-not-readable-sqlserver-logstash/307391 "2022-06-16T11:04:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Khadija\_BOUDINAR1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khadija_boudinar1/32/106922_2.png) [@Khadija\_BOUDINAR1](https://discuss.elastic.co/u/Khadija_BOUDINAR1)\
**Post date:** [June 16, 2022, 11:04am UTC](https://discuss.elastic.co/t/block-in-start-input-file-not-readable-sqlserver-logstash/307391/1 "2022-06-16T11:04:25Z")

</div>

Hi all,

I plan to load data from SQL Server database to Elastic. While trying to load this data using the Logstash JDBC plugin I am facing a problem. I found in the community errors like this but no solution,

Test: Copy the driver to the path "C:\Users\Lenovo\Desktop\ELK\logstash-8.1.0\logstash-core\lib\jars\mssql-jdbc-7.2.2.jre8.jar"  
`Error: unable to load sqljdbc4-2.0.jar from :jdbc_driver_library, file not readable (please check user and group permissions for the path) <`

myfile.conf

```auto
input {
  jdbc {
	jdbc_default_timezone => "America/New_York"
    jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
    jdbc_connection_string => "jdbc:sqlserver://localhost;databaseName=sales;user=admin;password=1234;"
    jdbc_user => ""
    jdbc_password => ""
    use_column_value => true
	tracking_column_type => "timestamp"
	tracking_column => "rml_lastupdate"
	statement => "SELECT * FROM Fevrier WHERE rml_lastupdate >= :sql_last_value order by rml_lastupdate"
	schedule => "*/5 * * * * *"
 }
}
output {
 elasticsearch {
	hosts => ["localhost:9200"]
	index => "cs_users"
	document_id => "%{Order ID}"
 }
}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 14, 2022, 11:04am UTC](https://discuss.elastic.co/t/block-in-start-input-file-not-readable-sqlserver-logstash/307391/2 "2022-07-14T11:04:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
