# Block in start\_input

**URL:** <https://discuss.elastic.co/t/block-in-start-input/243410>\
**Category:** Logstash\
**Created:** [August 1, 2020, 12:14am UTC](https://discuss.elastic.co/t/block-in-start-input/243410 "2020-08-01T00:14:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Inder](https://avatars.discourse-cdn.com/v4/letter/i/73ab20/32.png) [@Inder](https://discuss.elastic.co/u/Inder)\
**Post date:** [August 1, 2020, 12:14am UTC](https://discuss.elastic.co/t/block-in-start-input/243410/1 "2020-08-01T00:14:13Z")

</div>

Hi,  
This is my conf file:  
input {  
file {  
path =\> "/Users/Parm/cars.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
}

filter { csv {  
separator =\> ","  
columns =\> [ "maker", "model", "mileage", "manufacture\_year", "engine\_displacement",  
"engine\_power", "body\_type", "color\_slug", "stk\_year", "tranmission", "door\_count",  
"seat\_count", "fuel\_type", "date\_created", "date\_last\_seen", "price\_eur" ]  
}  
mutate {convert =\> ["mileage", "integer"]}  
mutate {convert =\> ["price\_eur", "float"]}  
mutate {convert =\> ["engine\_power", "integer"]}  
mutate {convert =\> ["door\_count", "integer"]}  
mutate {convert =\> ["seat\_count", "integer"]}  
}  
output {  
elasticsearch {  
hosts =\> "localhost"  
index =\> "cars"  
document\_type =\> "sold\_cars"  
}  
stdout {}  
}

I am getting this error when trying to upload to Kibana via logstash:

Watch with file and sincedb collections  
[2020-07-31T17:10:24,002][ERROR][logstash.javapipeline][main][25037192ef873c7bf18963c1adc495f35247161f16dda4bda89d7088a2027048] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::File start\_position=\>"beginning", path=\>["/Users/Parm/cars.csv"], id=\>"25037192ef873c7bf18963c1adc495f35247161f16dda4bda89d7088a2027048", sincedb\_path=\>"/dev/null", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_64fb0f18-321b-4a94-96b5-62f8596a3ec1", enable\_metric=\>true, charset=\>"UTF-8"\>, stat\_interval=\>1.0, discover\_interval=\>15, sincedb\_write\_interval=\>15.0, delimiter=\>"\n", close\_older=\>3600.0, mode=\>"tail", file\_completed\_action=\>"delete", sincedb\_clean\_after=\>1209600.0, file\_chunk\_size=\>32768, file\_chunk\_count=\>140737488355327, file\_sort\_by=\>"last\_modified", file\_sort\_direction=\>"asc", exit\_after\_read=\>false, check\_archive\_validity=\>false\>  
Error: Permission denied - Permission denied  
Exception: Errno::EACCES  
Stack: org/jruby/RubyFile.java:1267:in `utime' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in `block in touch'  
org/jruby/RubyArray.java:1809:in `each' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in `touch'  
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/sincedb\_collection.rb:22:in `initialize' /Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing_base.rb:62:in `build\_watch\_and\_dependencies'  
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing\_base.rb:56:in `initialize' /Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:345:in `start\_processing'  
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:361:in `run' /Users/Parm/logstash-7.8.1/logstash-core/lib/logstash/java_pipeline.rb:374:in `inputworker'  
/Users/Parm/logstash-7.8.1/logstash-core/lib/logstash/java\_pipeline.rb:365:in `block in start\_input'

* * *

I have given myself all rwx permissions and still get this error

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [August 1, 2020, 1:58am UTC](https://discuss.elastic.co/t/block-in-start-input/243410/2 "2020-08-01T01:58:07Z")

</div>

> [@Inder](#):
>
> Error: Permission denied - Permission denied  
> Exception: Errno::EACCES  
> Stack: org/jruby/RubyFile.java:1267:in `utime' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in ` block in touch'  
> org/jruby/RubyArray.java:1809:in `each' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in ` touch'  
> /Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/sincedb\_collection.rb:22:in `initialize'`

The permissions error occurs when trying to touch the sincedb. The [default](https://github.com/logstash-plugins/logstash-input-file/blob/be18de77292f0aafb667debbdef8fe7297065fe3/lib/logstash/inputs/file.rb#L122) path for the sincedb is under \<path.data\>/plugins/inputs/file. Make sure the user running logstash has write access to that directory.

If I recall correctly you can enable '--log.level debug' and it will give you the exact path of the sincedb.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2020, 1:58am UTC](https://discuss.elastic.co/t/block-in-start-input/243410/3 "2020-08-29T01:58:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
