# Blocked outputs

**URL:** <https://discuss.elastic.co/t/blocked-outputs/78881>\
**Category:** Logstash\
**Created:** [March 16, 2017, 2:47pm UTC](https://discuss.elastic.co/t/blocked-outputs/78881 "2017-03-16T14:47:26Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tcouto](https://avatars.discourse-cdn.com/v4/letter/t/9d8465/32.png) [@tcouto](https://discuss.elastic.co/u/tcouto)\
**Post date:** [March 16, 2017, 2:47pm UTC](https://discuss.elastic.co/t/blocked-outputs/78881/1 "2017-03-16T14:47:26Z")

</div>

Recently I had an issue where my Elastic Cloud instance was not responding well. Logstash was throwing a lot of errors about not being able to send events, and I noticed that some of my other outputs weren't getting processed, specifically critical exec outputs.

I'm running logstash-5.0.0-alpha5 which was upgraded from 2.3 and the elasticsearch-output version 4.1.3 which I think is 8 or 9 months old.

If one output is blocked is it expected that others will be? That the whole pipeline will be blocked?  
I wondering if this is related to outdated and alpha versions of the products or if this behavior is expected, and I should design my systems to handle this.

Here's the log:

```auto
{
  :timestamp=>"2017-03-12T22:44:35.915000-0700",
  :message=>"Encountered an unexpected error submitting a bulk request! Will retry.",
  :error_message=>"Cabin::Channel#error(message, data={}) - second argument you gave me wasa Array, I require a Hash.",
  :class=>"ArgumentError",
  :backtrace=>[
    "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/cabin-0.8.1/lib/cabin/mixins/logger.rb:72:in `error'",
    "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.3-java/lib/logstash/outputs/elasticsearch/common.rb:75:in `retrying_submit'",
    "org/jruby/RubyArray.java:1613:in `each'",
    "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.3-java/lib/logstash/outputs/elasticsearch/common.rb:75:in `retrying_submit'",
    "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.3-java/lib/logstash/outputs/elasticsearch/common.rb:23:in `multi_receive'",
    "org/jruby/RubyArray.java:1653:in `each_slice'",
    "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.3-java/lib/logstash/outputs/elasticsearch/common.rb:22:in `multi_receive'",
    "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:136:in `threadsafe_multi_receive'",
    "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:122:in `multi_receive'",
    "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:291:in `output_batch'",
    "org/jruby/RubyHash.java:1342:in `each'",
    "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:291:in `output_batch'",
    "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:242:in `worker_loop'",
    "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:215:in `start_workers'"
  ],
  :level=>:error
}

```

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [March 17, 2017, 6:32am UTC](https://discuss.elastic.co/t/blocked-outputs/78881/2 "2017-03-17T06:32:14Z")

</div>

> If one output is blocked is it expected that others will be? That the whole pipeline will be blocked?

Yes, this is expected.

---

<div class="post-metadata">

**Author:** ![tcouto](https://avatars.discourse-cdn.com/v4/letter/t/9d8465/32.png) [@tcouto](https://discuss.elastic.co/u/tcouto)\
**Post date:** [March 17, 2017, 4:00pm UTC](https://discuss.elastic.co/t/blocked-outputs/78881/3 "2017-03-17T16:00:42Z")

</div>

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 14, 2017, 4:00pm UTC](https://discuss.elastic.co/t/blocked-outputs/78881/4 "2017-04-14T16:00:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
