# Bootstrap check failure

**URL:** <https://discuss.elastic.co/t/bootstrap-check-failure/316025>\
**Category:** Elasticsearch\
**Created:** [October 7, 2022, 2:25am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025 "2022-10-07T02:25:49Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![rt\_888](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rt_888/32/110632_2.png) [@rt\_888](https://discuss.elastic.co/u/rt_888)\
**Post date:** [October 7, 2022, 2:25am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/1 "2022-10-07T02:25:49Z")

</div>

I tried using ES on AWS server of ubutu image, and modify the elasticsearch.yml file of node, discovery.seed\_hosts, master node . But got error with `bootstrap node validation exception`  
and it shows "at least one of [discovery.seed\_hosts, discovery.seed\_providers, cluster.initial\_master\_nodes] must be configured" which i already did. Thank youu

```auto
Below is my elasticsearch.yml configuration
cluster.name: es-demo
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: node-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: /var/lib/elasticsearch
#
# Path to log files:
#
path.logs: /var/log/elasticsearch
network.host: ip1

 default Elasticsearch listens for HTTP traffic on the first free port it
# finds starting at 9200. Set a specific HTTP port here:
#
http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
#The default list of hosts is ["127.0.0.1", "[::1]"]
#
discovery.seed_hosts: ["ip1(the ip of 1st node)", "ip2"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
cluster.initial_master_nodes: ["ip1"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true
#
node.master: true

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 10, 2022, 11:39pm UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/2 "2022-10-10T23:39:46Z")

</div>

Can you please post the entire Elasticsearch log from startup to this error?

---

<div class="post-metadata">

**Author:** ![rt\_888](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rt_888/32/110632_2.png) [@rt\_888](https://discuss.elastic.co/u/rt_888)\
**Post date:** [October 11, 2022, 3:27am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/3 "2022-10-11T03:27:13Z")

</div>

@warkolm Hmm it is already resolved anyway, thank you

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 11, 2022, 3:28am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/4 "2022-10-11T03:28:35Z")

</div>

Can you share what it was, it might help someone in future.

---

<div class="post-metadata">

**Author:** ![rt\_888](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rt_888/32/110632_2.png) [@rt\_888](https://discuss.elastic.co/u/rt_888)\
**Post date:** [October 11, 2022, 3:46am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/5 "2022-10-11T03:46:54Z")

</div>

hmm, sorry because i didnt copy the whole log and i think the problem have to do with the node configuration in elasticsearch.yml file

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 8, 2022, 3:47am UTC](https://discuss.elastic.co/t/bootstrap-check-failure/316025/6 "2022-11-08T03:47:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
