# Bootstrap Error

**URL:** <https://discuss.elastic.co/t/bootstrap-error/64426>\
**Category:** Elasticsearch\
**Created:** [October 31, 2016, 10:47am UTC](https://discuss.elastic.co/t/bootstrap-error/64426 "2016-10-31T10:47:59Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tim\_James](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim_james/32/55697_2.png) [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Post date:** [October 31, 2016, 10:47am UTC](https://discuss.elastic.co/t/bootstrap-error/64426/1 "2016-10-31T10:47:59Z")

</div>

Hi,

Just trying out 5.0.0. On my previous 2.4 instance I had set network.host to 0.0.0.0. as otherwise I couldn't connect to Elasticsearch from logstash.

In 5.0.0, if I make the same change, Elasticsearch won't startup, it says:

[2016-10-31T10:32:58,446][INFO][o.e.b.BootstrapCheck] [gbvlixaacas22t] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
ERROR: bootstrap checks failed

If I don't make this change, Elasticsearch starts up but logstash gives:

Connection refused {:class=\>"Manticore::SocketException", :level=\>:error}

This is on RHEL.

No problems with the old version.

Thanks

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 31, 2016, 11:49am UTC](https://discuss.elastic.co/t/bootstrap-error/64426/2 "2016-10-31T11:49:19Z")

</div>

Read the full log. It will tell you what is wrong.

---

<div class="post-metadata">

**Author:** ![Tim\_James](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim_james/32/55697_2.png) [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Post date:** [October 31, 2016, 12:27pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/3 "2016-10-31T12:27:12Z")

</div>

It says:

[2016-10-31T10:32:58,446][INFO][o.e.b.BootstrapCheck] [gbvlixaacas22t] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
[2016-10-31T10:32:58,458][ERROR][o.e.b.Bootstrap] [gbvlixaacas22t] node validation exception  
bootstrap checks failed

It then only has the usual warnings which I don't plan to change as this is only a tiny test system and the same messages came up in the old version:

max file descriptors [32000] for elasticsearch process likely too low, increase to at least [65536]  
max number of threads [1024] for user [uktja] likely too low, increase to at least [2048]  
max virtual memory areas vm.max\_map\_count [65530] likely too low, increase to at least [262144]

What is a node validation exception?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 31, 2016, 12:47pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/4 "2016-10-31T12:47:53Z")

</div>

You have to fix all the latest messages.

---

<div class="post-metadata">

**Author:** ![Tim\_James](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim_james/32/55697_2.png) [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Post date:** [October 31, 2016, 12:51pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/5 "2016-10-31T12:51:27Z")

</div>

These type of messages were just warnings in the previous release, is this release more fussy.  
Unfortunately I can't change these values, so I guess I can't upgrade.

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [October 31, 2016, 1:07pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/6 "2016-10-31T13:07:16Z")

</div>

If you bind to a non-local IP these things are enforced. We explain the reasoning on the PRs and reexplain [here](https://www.elastic.co/blog/bootstrap_checks_annoying_instead_of_devastating). We have no plans at this point to give an opt out flag.

---

<div class="post-metadata">

**Author:** ![Tim\_James](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim_james/32/55697_2.png) [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Post date:** [October 31, 2016, 2:39pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/7 "2016-10-31T14:39:24Z")

</div>

Thanks for the link, it was interesting and I understand the points.

It's disappointing as I now can't test the new version on my dev servers as I'd like,.

If there's a vote at any point, put me down for an opt-out :-). I think it can be left up to me whether I am prepared to risk later issues and I am capable of deciding which of my servers is a test and which is prod.

---

<div class="post-metadata">

**Author:** ![jamiesmithnc](https://avatars.discourse-cdn.com/v4/letter/j/a9a28c/32.png) [@jamiesmithnc](https://discuss.elastic.co/u/jamiesmithnc)\
**Post date:** [October 31, 2016, 3:38pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/8 "2016-10-31T15:38:21Z")

</div>

Same problem here - Trying to run in a container for dev & test purposes, I cannot change the kernel parameters of the host.

I understand the concept, but not giving an opt-out just broke any chance for us to upgrade to 5, across the board.

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [October 31, 2016, 8:45pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/9 "2016-10-31T20:45:36Z")

</div>

We've just patched the docs to explain a way to opt out that ought to work fine for you. It might take a while to build so here is a link to the fix: [https://github.com/elastic/elasticsearch/pull/21220/files](https://github.com/elastic/elasticsearch/pull/21220/files)

Essentially, set `http.host` to the non-local IP while keeping `network.host` at its default. You can't form a cluster but you can test against a single node. If you want a cluster you'll need to make the bootstrap checks happy.

---

<div class="post-metadata">

**Author:** ![Tim\_James](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim_james/32/55697_2.png) [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Post date:** [November 1, 2016, 8:48am UTC](https://discuss.elastic.co/t/bootstrap-error/64426/10 "2016-11-01T08:48:50Z")

</div>

Thanks, I appreciate that. I can at least try it out in a limited way, and that suggestion does indeed work for me.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:07pm UTC](https://discuss.elastic.co/t/bootstrap-error/64426/11 "2017-07-05T22:07:57Z")

</div>


