# Breaking \_ingest.timestamp change in ES 5.2.0

**URL:** <https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575>\
**Category:** Elasticsearch\
**Created:** [February 1, 2017, 7:05pm UTC](https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575 "2017-02-01T19:05:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jin\_Wang](https://avatars.discourse-cdn.com/v4/letter/j/73ab20/32.png) [@Jin\_Wang](https://discuss.elastic.co/u/Jin_Wang)\
**Post date:** [February 1, 2017, 7:05pm UTC](https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575/1 "2017-02-01T19:05:49Z")

</div>

I have a very simple ingest set processor which copied from our official document, it stop working after upgrading to 5.2.0 yesterday.  
{  
"set": {  
"field": "received"  
"value": "{{\_ingest.timestamp}}"  
}  
}

now every document indexing was reject and throw below errors.  
{  
"error": {  
"root\_cause": [  
{  
"type": "mapper\_parsing\_exception",  
"reason": "failed to parse [received]"  
}  
],  
"type": "mapper\_parsing\_exception",  
"reason": "failed to parse [timestamp]",  
"caused\_by": {  
"type": "illegal\_argument\_exception",  
"reason": "Invalid format: "Wed Feb 01 19:02:14 UTC 2017""  
}  
},  
"status": 400  
}

Any suggestion about how to get it working without changing my mapping?

Thanks in advance.

---

<div class="post-metadata">

**Author:** ![Jin\_Wang](https://avatars.discourse-cdn.com/v4/letter/j/73ab20/32.png) [@Jin\_Wang](https://discuss.elastic.co/u/Jin_Wang)\
**Post date:** [February 2, 2017, 11:34pm UTC](https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575/2 "2017-02-02T23:34:07Z")

</div>

i solved the problem by replacing the set processor with script processor without changing mapping. possible it is helpful to well document how to use set processor for handling this case.

---

<div class="post-metadata">

**Author:** ![philomatic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/philomatic/32/15291_2.png) [@philomatic](https://discuss.elastic.co/u/philomatic)\
**Post date:** [February 7, 2017, 10:53am UTC](https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575/3 "2017-02-07T10:53:43Z")

</div>

Yes, indeed, I have the same problem.

Unfortunately, imho the docs about ingest.timestamp are pretty incomplete.  
There's only one paragraph about it in

[https://www.elastic.co/guide/en/elasticsearch/reference/current/accessing-data-in-pipelines.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/accessing-data-in-pipelines.html)

where's no information about format or options. As this "replaces" the automatic timestamp mechanic of elasticsearch, I think more information should be supplied.

Anyway, could you please so kind to share your script?  
I'd like to keep the default timestamp format and don't change the mapping.

Best regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 7, 2017, 10:53am UTC](https://discuss.elastic.co/t/breaking--ingest-timestamp-change-in-es-5-2-0/73575/4 "2017-03-07T10:53:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
