# Brew services starts elasticsearch as root

**URL:** <https://discuss.elastic.co/t/brew-services-starts-elasticsearch-as-root/295409>\
**Category:** Elasticsearch\
**Tags:** homebrew\
**Created:** [January 26, 2022, 12:51am UTC](https://discuss.elastic.co/t/brew-services-starts-elasticsearch-as-root/295409 "2022-01-26T00:51:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Stephen\_Moore](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephen_moore/32/100874_2.png) [@Stephen\_Moore](https://discuss.elastic.co/u/Stephen_Moore)\
**Post date:** [January 26, 2022, 12:51am UTC](https://discuss.elastic.co/t/brew-services-starts-elasticsearch-as-root/295409/1 "2022-01-26T00:51:48Z")

</div>

Hello,

I've installed Elasticsearch with

```auto
brew tap elastic/tap
brew install elastic/tap/elasticsearch-full

```

And it seems the brew service for it wants to run as root and so Elasticsearch fails to start

```auto
╰─ brew services
Warning: Calling bottle :unneeded is deprecated! There is no replacement.
Please report this issue to the elastic/tap tap (not Homebrew/brew or Homebrew/core):
  /opt/homebrew/Library/Taps/elastic/homebrew-tap/Formula/elasticsearch-full.rb:9

Name Status User File
caddy none
dnsmasq none root
elasticsearch-full error 19968 root ~/Library/LaunchAgents/homebrew.mxcl.elasticsearch-full.plist

```

```auto
╰─ tail -n20 /opt/homebrew/var/log/elasticsearch.log
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81) ~[elasticsearch-7.15.2.jar:7.15.2]
Caused by: java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:103) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:170) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:399) ~[elasticsearch-7.15.2.jar:7.15.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:167) ~[elasticsearch-7.15.2.jar:7.15.2]
        ... 6 more
uncaught exception in thread [main]
java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:103)
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:170)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:399)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:167)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:158)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:75)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:114)
        at org.elasticsearch.cli.Command.main(Command.java:79)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:123)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81)
For complete error details, refer to the log at /opt/homebrew/var/log/elasticsearch/elasticsearch_brew.log

```

How do I make brew services not start it as root?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 23, 2022, 12:52am UTC](https://discuss.elastic.co/t/brew-services-starts-elasticsearch-as-root/295409/2 "2022-02-23T00:52:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
