# \[Bug?\] App Search Dashboard Fails To Load After Restarting The Server

**URL:** <https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237>\
**Category:** Elastic Search\
**Tags:** elastic-app-search\
**Created:** [November 2, 2019, 1:26pm UTC](https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237 "2019-11-02T13:26:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![The-Big-K](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/the-big-k/32/56199_2.png) [@The-Big-K](https://discuss.elastic.co/u/The-Big-K)\
**Post date:** [November 2, 2019, 1:26pm UTC](https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237/1 "2019-11-02T13:26:28Z")

</div>

I'm trying to install app search on ubuntu 18.04 and was able to successfully setup. Here's an overview of my setup:

1. Installed Elasticsearch and App Search 7.4.2 via apt
2. Added `xpack.security.enabled: true` to `elasticsearch.yml`
3. Generated automatic passwords by running `bin/elasticsearch-setup-passwords auto` and noted down the passwords.
4. Added the following to app-search.yml:  
allow\_es\_settings\_modification: true  
app\_search.auth.source: standard  
elasticsearch.username: elastic  
elasticsearch.password: \<password generated in step #3\>
5. Ran app-search by running `bin/app-search`

I then noted down the username and default password generated  
username: [app-search@example.com](mailto:app-search@example.com)  
password: hnrxxam9khgtq38u

I was able to login to the app-search console. I however then stopped the app-search by pressing CTRL+C and tried to restart with by running `bin/app-search`.

The server did start; but now I could not get to the dashboard again. The console output was as follows, while the chrome got into endless waiting for page state -

```auto
**app-server.1 |** [2019-11-02T13:20:08.019+00:00][6800][2268][app-server][INFO]: [c1d9ba72-f40e-4925-b5f0-56c1e9744054] Started GET "/" for 49.36.27.83 at 2019-11-02 13:20:08 +0000
**app-server.1 |** [2019-11-02T13:20:08.044+00:00][6800][2268][action_controller][INFO]: [c1d9ba72-f40e-4925-b5f0-56c1e9744054] Processing by LocoTogo::HomeController#index as HTML
**app-server.1 |** [2019-11-02T13:20:08.047+00:00][6800][2268][action_controller][INFO]: [c1d9ba72-f40e-4925-b5f0-56c1e9744054] Parameters: {"host"=>"139.59.11.80:3002", "protocol"=>"http"}
**app-server.1 |** [2019-11-02T13:20:08.164+00:00][6800][2268][action_controller][INFO]: [c1d9ba72-f40e-4925-b5f0-56c1e9744054] Redirected to http://139.59.11.80:3002/login
**app-server.1 |** [2019-11-02T13:20:08.180+00:00][6800][2268][action_controller][INFO]: [c1d9ba72-f40e-4925-b5f0-56c1e9744054] Completed 302 Found in 130ms
**app-server.1 |** [2019-11-02T13:20:08.234+00:00][6800][2250][app-server][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Started GET "/login" for 49.36.27.83 at 2019-11-02 13:20:08 +0000
**app-server.1 |** [2019-11-02T13:20:08.245+00:00][6800][2250][action_controller][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Processing by LocoTogo::SessionsController#login as HTML
**app-server.1 |** [2019-11-02T13:20:08.248+00:00][6800][2250][action_controller][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Parameters: {"host"=>"139.59.11.80:3002", "protocol"=>"http"}
**app-server.1 |** [2019-11-02T13:20:08.295+00:00][6800][2250][action_view][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Rendered eui_icons/_close.html (0.4ms)
**app-server.1 |** [2019-11-02T13:20:08.306+00:00][6800][2250][action_view][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Rendered eui_icons/_lock.html (0.9ms)
**app-server.1 |** [2019-11-02T13:20:08.317+00:00][6800][2250][action_view][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Rendered loco_togo/app/views/loco_togo/sessions/login.html.rb (47.4ms)
**app-server.1 |** [2019-11-02T13:20:08.320+00:00][6800][2250][action_controller][INFO]: [eb2e7e67-bfa5-4349-aaad-1add172b44ac] Completed 200 OK in 71ms (Views: 52.2ms)

```

I can confirm that I've repeatedly reproduced this issue. Can someone from Elastic team confirm that this is an issue? Or is there something wrong with my configuration?

---

<div class="post-metadata">

**Author:** ![The-Big-K](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/the-big-k/32/56199_2.png) [@The-Big-K](https://discuss.elastic.co/u/The-Big-K)\
**Post date:** [November 2, 2019, 1:47pm UTC](https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237/2 "2019-11-02T13:47:35Z")

</div>

**Update 1:** I've sent the diagnostics folder to support at swiftype dot com [#00405240]. I hope someone will look into this issue and respond.

**Update 2** : Here's an interesting observation I made. After restarting the server, if I just let chrome try to access the dashboard - it takes Chrome about 20-25 minutes of 'waiting' to fetch the page. I'm not sure what really happens in those ~25 minutes; because console doesn't output anything when the page actually loads. What could possibly be taking ~25 minutes to complete in the backend?

---

<div class="post-metadata">

**Author:** ![orhantoy](https://avatars.discourse-cdn.com/v4/letter/o/c5a1d2/32.png) [@orhantoy](https://discuss.elastic.co/u/orhantoy)\
**Post date:** [November 5, 2019, 6:23pm UTC](https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237/3 "2019-11-05T18:23:57Z")

</div>

Thanks for reporting this @The-Big-K

From the logs it seems like the response times are in the milliseconds, so the 20-25 minute waiting time seems weird. Wondering if this can be a browser related thing; do you experience the same behavior with other browsers than Chrome?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 3, 2019, 6:24pm UTC](https://discuss.elastic.co/t/bug-app-search-dashboard-fails-to-load-after-restarting-the-server/206237/4 "2019-12-03T18:24:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
