# Bulk Indexing not working \[resolved\]

**URL:** <https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935>\
**Category:** Elasticsearch\
**Created:** [October 9, 2015, 8:23pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935 "2015-10-09T20:23:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Phrozyn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phrozyn/32/5207_2.png) [@Phrozyn](https://discuss.elastic.co/u/Phrozyn)\
**Post date:** [October 9, 2015, 8:23pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935/1 "2015-10-09T20:23:50Z")

</div>

Hi!

I've created mappings and have imported data successfully.

However when I go to elasticsearch using /\_plugin/head/ on the browser tab and click on the index or it's types I created - nothing populates in the right pane.

{"create":{ "\_index":"nexpose","\_type":"exception","\_id":"AVBOLQbukTljbbvdgEfa","\_version":1,"status":201}  
On the indices tab I show Index: nexpose Size: 20.1ki/20.1ki Docs: 4

Under Cluster Overview when I click on info index status I show it's started.  
Logs show the following every time I click on one fo the types, it's referencing a logstash and the tutorial bank entries though, not the nexpose ones. Does this indicate corruption?

The events for bank and logstash and shakespeare show up fine, however the entries for nexpose do not even though they received status 201.

[2015-10-09 20:19:44,664][DEBUG][action.search.type] [Gargantus] [logstash-2015.10.09][0], node[sCJKvgNvScmF-v-fFF0ShA], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@6a51d8a] lastShard [true]  
org.elasticsearch.search.SearchParseException: [logstash-2015.10.09][0]: query[ConstantScore(_:_)],from[0],size[50]: Parse Failure [Failed to parse source [{"fields":["\_parent","\_source"],"query":{"bool":{"must":[],"must\_not":[],"should":[{"match\_all":{}}]}},"from":0,"size":50,"sort":[{"\_type":{"reverse":false}}],"facets":{},"version":true}]]  
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:747)  
at org.elasticsearch.search.SearchService.createContext(SearchService.java:572)  
at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:544)  
at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:306)  
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:231)  
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:228)  
at org.elasticsearch.search.action.SearchServiceTransportAction$23.run(SearchServiceTransportAction.java:559)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.search.SearchParseException: [logstash-2015.10.09][0]: query[ConstantScore(_:_)],from[0],size[50]: Parse Failure [No mapping found for [\_type] in order to sort on]  
at org.elasticsearch.search.sort.SortParseElement.addSortField(SortParseElement.java:214)  
at org.elasticsearch.search.sort.SortParseElement.addCompoundSortField(SortParseElement.java:188)  
at org.elasticsearch.search.sort.SortParseElement.parse(SortParseElement.java:86)  
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:731)

[2015-10-09 20:19:44,665][DEBUG][action.search.type] [Gargantus] [bank][1], node[sCJKvgNvScmF-v-fFF0ShA], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@6a51d8a] lastShard [true]  
org.elasticsearch.search.SearchParseException: [bank][1]: query[ConstantScore(_:_)],from[0],size[50]: Parse Failure [Failed to parse source [{"fields":["\_parent","\_source"],"query":{"bool":{"must":[],"must\_not":[],"should":[{"match\_all":{}}]}},"from":0,"size":50,"sort":[{"\_type":{"reverse":false}}],"facets":{},"version":true}]]  
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:747)  
at org.elasticsearch.search.SearchService.createContext(SearchService.java:572)  
at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:544)  
at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:306)  
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:231)  
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:228)  
at org.elasticsearch.search.action.SearchServiceTransportAction$23.run(SearchServiceTransportAction.java:559)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.search.SearchParseException: [bank][1]: query[ConstantScore(_:_)],from[0],size[50]: Parse Failure [No mapping found for [\_type] in order to sort on]  
at org.elasticsearch.search.sort.SortParseElement.addSortField(SortParseElement.java:214)  
at org.elasticsearch.search.sort.SortParseElement.addCompoundSortField(SortParseElement.java:188)  
at org.elasticsearch.search.sort.SortParseElement.parse(SortParseElement.java:86)  
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:731)

---

<div class="post-metadata">

**Author:** ![Phrozyn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phrozyn/32/5207_2.png) [@Phrozyn](https://discuss.elastic.co/u/Phrozyn)\
**Post date:** [October 9, 2015, 9:08pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935/2 "2015-10-09T21:08:04Z")

</div>

Also, it did work a week ago - I blew it all away and redid it to ensure I had everything documented only to find the second time around that I have problems.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 10, 2015, 3:51am UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935/3 "2015-10-10T03:51:11Z")

</div>

> [@Phrozyn](#):
>
> aused by: org.elasticsearch.search.SearchParseException: [logstash-2015.10.09][0]: query[ConstantScore(:)],from[0],size[50]: Parse Failure [No mapping found for [\_type] in order to sort on]

I'd check the mapping for your Logstash indices first.

---

<div class="post-metadata">

**Author:** ![Phrozyn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phrozyn/32/5207_2.png) [@Phrozyn](https://discuss.elastic.co/u/Phrozyn)\
**Post date:** [October 10, 2015, 8:36pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935/4 "2015-10-10T20:36:50Z")

</div>

it was a stray comma, I couldn't see it so I had a friend review.

Thank you warkolm!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:45pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-working-resolved/31935/5 "2017-07-05T23:45:31Z")

</div>


