# Bunch of errors when running curator test suite command

**URL:** <https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449>\
**Category:** Elasticsearch\
**Created:** [October 10, 2017, 10:38pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449 "2017-10-10T22:38:46Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![atgraphy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/atgraphy/32/22950_2.png) [@atgraphy](https://discuss.elastic.co/u/atgraphy)\
**Post date:** [October 10, 2017, 10:38pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/1 "2017-10-10T22:38:46Z")

</div>

When I run python [setup.py](http://setup.py) test, I get this output. Does anyone get the same error?

```auto
-----
No handlers could be found for logger "elasticsearch.trace"
test_add_and_remove (test.integration.test_alias.TestCLIAlias) ... FAIL
ERROR
test_add_only (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_add_only_skip_closed (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_add_only_with_extra_settings (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_add_with_empty_list (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_add_with_empty_remove (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_alias_remove_only (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_extra_options (test.integration.test_alias.TestCLIAlias) ... ERROR
test_no_add_remove (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_no_alias (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_remove_index_not_in_alias (test.integration.test_alias.TestCLIAlias) ... FAIL
ERROR
test_remove_with_empty_add (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_remove_with_empty_list (test.integration.test_alias.TestCLIAlias) ... ERROR
ERROR
test_exclude (test.integration.test_allocation.TestCLIAllocation) ... ERROR
ERROR
more-----
======================================================================
ERROR: test_add_only (test.integration.test_alias.TestCLIAlias)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/opt/synced/test/integration/test_alias.py", line 26, in test_add_only
    self.create_index('my_index')
  File "/var/opt/synced/test/integration/ __init__.py", line 121, in create_index
    body={'settings': {'number_of_shards': shards, 'number_of_replicas': 0}}
  File "/usr/local/lib/python2.7/dist-packages/elasticsearch/client/utils.py", line 69, in _wrapped
    return func(*args, params=params, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/elasticsearch/client/indices.py", line 110, in create
    params=params, body=body)
  File "/usr/local/lib/python2.7/dist-packages/elasticsearch/transport.py", line 327, in perform_request
    status, headers, data = connection.perform_request(method, url, params, body, ignore=ignore, timeout=timeout)
  File "/usr/local/lib/python2.7/dist-packages/elasticsearch/connection/http_urllib3.py", line 110, in perform_request
    self._raise_error(response.status, raw_data)
  File "/usr/local/lib/python2.7/dist-packages/elasticsearch/connection/base.py", line 114, in _raise_error
    raise HTTP_EXCEPTIONS.get(status_code, TransportError)(status_code, error_message, additional_info)
RequestError: TransportError(400, u'index_already_exists_exception', u'already exists')
-------------------- >> begin captured logging << --------------------
DEBUG urllib3.util.retry from_int:200 Converted retries value: False -> Retry(total=False, connect=None, read=None, redirect=0, status=None)
DEBUG urllib3.connectionpool _make_request:396 http://localhost:9280 "PUT /my_index HTTP/1.1" 400 211
WARNING elasticsearch log_request_fail:88 PUT /my_index [status:400 request:0.001s]
DEBUG elasticsearch log_request_fail:96 > {"settings": {"number_of_replicas": 0, "number_of_shards": 1}}
DEBUG elasticsearch log_request_fail:99 < {"error":{"root_cause":[{"type":"index_already_exists_exception","reason":"already exists","index":"my_index"}],"type":"index_already_exists_exception","reason":"already exists","index":"my_index"},"status":400}
--------------------- >> end captured logging << ---------------------

--- more----

```

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 10, 2017, 10:58pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/2 "2017-10-10T22:58:06Z")

</div>

Please encapsulate pasted text in \< / \> code tags, or within triple back-ticks, like this:

````
```
PASTED TEXT
```

````

It's too hard to read errors without this consistency.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 10, 2017, 11:04pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/3 "2017-10-10T23:04:11Z")

</div>

If the Elasticsearch instance you're running against has _any_ index in it, you will get some failures.

How are you launching it? I assume you set the appropriate environment variables to change the default `http://localhost:9200` that it expects, as I see `http://localhost:9280` in your output.

Is there something else at `http://localhost:9280`?

Currently, Curator is running tests using Travis CI, as defined in [this file](https://github.com/elastic/curator/blob/v5.2.0/.travis.yml). It represents a mash-up of each of these versions:

```auto
python:
  - "2.7"
  - "3.4"
  - "3.5"
  - "3.6"

env:
  - ES_VERSION=5.0.2
  - ES_VERSION=5.1.2
  - ES_VERSION=5.2.2
  - ES_VERSION=5.3.3
  - ES_VERSION=5.4.3
  - ES_VERSION=5.5.2

```

The `master` branch has added 5.6.2 as yet another ES\_VERSION. Every commit results in each python version defined being tested against each ES\_VERSION. It's a lot of tests. They're all passing.

Note: The current branch of Curator _will not_ run against Elasticsearch 6.x

---

<div class="post-metadata">

**Author:** ![atgraphy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/atgraphy/32/22950_2.png) [@atgraphy](https://discuss.elastic.co/u/atgraphy)\
**Post date:** [October 10, 2017, 11:14pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/4 "2017-10-10T23:14:51Z")

</div>

When I do; curl localhost:9280/\_cat/indices, i only see .kibana if that's what you're referring to. Currently the elasticsearch version im running is 2.4.4 (i got that version from curl localhost:9280), and i'm using the curator 4.x branch.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 10, 2017, 11:17pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/5 "2017-10-10T23:17:19Z")

</div>

That will do it _every_ time. You _cannot_ have a Kibana instance connected to this Elasticsearch. It _must_ be standalone, with nothing else connected. The reason these integration tests are failing is because the `.kibana` index is not expected. When the test completes (failed or passed), it cleans up _all_ indices in the cluster in preparation for the next test. The problem is that Kibana will automatically create another `.kibana` index if the original was deleted.

---

<div class="post-metadata">

**Author:** ![atgraphy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/atgraphy/32/22950_2.png) [@atgraphy](https://discuss.elastic.co/u/atgraphy)\
**Post date:** [October 10, 2017, 11:42pm UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/6 "2017-10-10T23:42:30Z")

</div>

Having trouble trying to detach kibana. I attempted to just stop the service that prevents it from recreating .kibana, but I still get the same error. Should I continue trying to detach?

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 11, 2017, 3:27am UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/7 "2017-10-11T03:27:56Z")

</div>

You should not be using an Elasticsearch instance for testing that is used for anything else. If you're having a hard time detaching, you should instead spin up another isolated instance of Elasticsearch and run tests against that.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 8, 2017, 3:28am UTC](https://discuss.elastic.co/t/bunch-of-errors-when-running-curator-test-suite-command/103449/8 "2017-11-08T03:28:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
