# Bypassing the updating script.max\_size\_in\_bytes in ES 6.5.2

**URL:** <https://discuss.elastic.co/t/bypassing-the-updating-script-max-size-in-bytes-in-es-6-5-2/179925>\
**Category:** Elasticsearch\
**Created:** [May 7, 2019, 9:09am UTC](https://discuss.elastic.co/t/bypassing-the-updating-script-max-size-in-bytes-in-es-6-5-2/179925 "2019-05-07T09:09:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ken.le](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ken.le/32/45388_2.png) [@ken.le](https://discuss.elastic.co/u/ken.le)\
**Post date:** [May 7, 2019, 9:09am UTC](https://discuss.elastic.co/t/bypassing-the-updating-script-max-size-in-bytes-in-es-6-5-2/179925/1 "2019-05-07T09:09:08Z")

</div>

Hi,

I'm currently ingesting data into ES, but facing this issue:

// Scripts may be no longer than 16384 characters. The passed in script is 16887 characters. Consider using a plugin if a script longer than this length is a requirement.

I found that the script.max\_size\_in\_bytes can be changed dynamically in ES 7.0. However, in my current use cases, I don't think that upgrade to ES 7.0 is a good idea because I have to dump a lot of data after the upgrading process.

Does ES 6.5.2 provide any settings that I can configure to bypass the script.max\_size\_in\_bytes? I mean that ES only receives 16384 characters from the script and cutoff the rest, so that I can re-ingest only the missing data?

Thank you.

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [May 19, 2019, 7:37pm UTC](https://discuss.elastic.co/t/bypassing-the-updating-script-max-size-in-bytes-in-es-6-5-2/179925/2 "2019-05-19T19:37:30Z")

</div>

There isn't a way in 6.5.2 to increase the max script size. The entire request would be rejected when the script fails to compile due to this error. I recommend doing a thorough review of your script to decrease its length, as 16k is an enormous script.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 16, 2019, 7:40pm UTC](https://discuss.elastic.co/t/bypassing-the-updating-script-max-size-in-bytes-in-es-6-5-2/179925/3 "2019-06-16T19:40:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
