# Bytes Sent shown as 0 for beats monitoring

**URL:** https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928
**Category:** Beats
**Tags:** elastic-stack-monitoring, filebeat
**Created:** [January 11, 2019, 4:11pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928 "2019-01-11T16:11:49Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)
#### Post date: [January 11, 2019, 4:11pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/1 "2019-01-11T16:11:49Z")

</div>

I have enabled beats monitoring by setting the below in the filebeats.yml

```
xpack.monitoring:
   enabled: true
   elasticsearch:
       hosts: ["http://host1:port","http://host2:port"]

```

But in Kibana, though i am getting the count of events, I am not getting any value for Bytes Sent

 ![01%20PM](https://us1.discourse-cdn.com/elastic/original/3X/0/d/0d084438238338c769b828b82f38a0536886c900.png)

Please help me with any missing configuration in my setup.

Thank you

---

<div class="post-metadata">

### Author: ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)
#### Post date: [January 11, 2019, 4:26pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/2 "2019-01-11T16:26:29Z")

</div>

Hi, what version of Filebeat and Kibana are you using? Also, what operating system are you on?

---

<div class="post-metadata">

### Author: ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)
#### Post date: [January 11, 2019, 4:48pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/3 "2019-01-11T16:48:50Z")

</div>

Thank you for the prompt reply

I am running Filebeat 6.5.3 on CentOS release 6.9 (Final)

My Kibana is Version: 6.4.2 on CentOS Linux release 7.5.1804

---

<div class="post-metadata">

### Author: ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)
#### Post date: [January 11, 2019, 6:17pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/4 "2019-01-11T18:17:56Z")

</div>

I just setup the same versions as you but was unable to reproduce the issue. Could you check if your Filebeat log contains an `ERROR` messages?

---

<div class="post-metadata">

### Author: ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)
#### Post date: [January 12, 2019, 3:18am UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/5 "2019-01-12T03:18:36Z")

</div>

below are the 2 error repeating in the logs but I couldn't find reasons for the same

```
ERROR pipeline/output.go:121 Failed to publish events: Post http://host1:port/_xpack/monitoring/_bulk?interval=10s&system_api_version=6&system_id=beats: net/http: request can
celed (Client.Timeout exceeded while awaiting headers)

ERROR pipeline/output.go:100 Failed to connect to backoff(failover(publish(elasticsearch(http://Host1:port)),publish(elasticsearch(http://host2:port)))): X-Pack capabilities query failed with: Get http://host1:port/_xpack?filter_path=features.monitoring.enabled: net/http: request canceled (Client.Timeout exceeded while awaiting headers)

```

I am able to get Monitoring info for other components in the stack.

---

<div class="post-metadata">

### Author: ![xeraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xeraa/32/48181_2.png) [@xeraa](https://discuss.elastic.co/u/xeraa)
#### Post date: [January 14, 2019, 11:55am UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/6 "2019-01-14T11:55:37Z")

</div>

And that connection is working in general — no firewall blocking it for example? So a simple curl call from the affected instances against both Elasticsearch hosts is succeeding?

Connection error sounds like something relatively low level failing IMO.

---

<div class="post-metadata">

### Author: ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)
#### Post date: [January 14, 2019, 12:10pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/7 "2019-01-14T12:10:02Z")

</div>

I understand that, but why am I able to get the event count and not the bytes.  
The screen shot in the first post shows the event count, but the bytes sent us 0.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 11, 2019, 12:10pm UTC](https://discuss.elastic.co/t/bytes-sent-shown-as-0-for-beats-monitoring/163928/8 "2019-02-11T12:10:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
