# c.a.a.p.i.BasicProfileConfigFileLoader noise

**URL:** <https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [June 20, 2022, 9:50am UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630 "2022-06-20T09:50:07Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anarhyst266](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anarhyst266/32/107268_2.png) [@Anarhyst266](https://discuss.elastic.co/u/Anarhyst266)\
**Post date:** [June 20, 2022, 9:50am UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/1 "2022-06-20T09:50:07Z")

</div>

When I'm trying to set logger.level to warn in my ES 8.1.3(also checked on 8.2.3) I've got the noise WARN message

`"message":"Unable to load config file null", "ecs.version": "1.2.0","service.name":"ES_ECS","event.dataset":"elasticsearch.server","process.thread.name":"main","log.logger":"com.amazonaws.auth.profile.internal.BasicProfileConfigFileLoader","elasticsearch.node.name":"test","elasticsearch.cluster.name":"docker-cluster","error.type":"java.security.AccessControlException","error.message":"access denied (\"java.io.FilePermission\" \"/usr/share/elasticsearch/.aws/config\" \"read\")","error.stack_trace":"java.security.AccessControlException: access denied (\"java.io.FilePermission\" \"/usr/share/elasticsearch/.aws/config\" \"read\")\n\tat java.base/java.security.AccessControlContext.checkPermission(AccessControlContext.java:485)\n\tat java.base/java.security.AccessController.checkPermission(AccessController.java:1068)\n\tat java.base/java.lang.SecurityManager.checkPermission(SecurityManager.java:411)\n\tat java.base/java.lang.SecurityManager.checkRead(SecurityManager.java:751)\n\tat java.base/java.io.File.exists(File.java:829)\n\tat com.amazonaws.profile.path.config.SharedConfigDefaultLocationProvider.getLocation(SharedConfigDefaultLocationProvider.java:36)\n\tat com.amazonaws.profile.path.AwsProfileFileLocationProviderChain.getLocation(AwsProfileFileLocationProviderChain.java:41)\n\tat com.amazonaws.auth.profile.internal.BasicProfileConfigFileLoader.getProfilesConfigFile(BasicProfileConfigFileLoader.java:69)\n\tat com.amazonaws.auth.profile.internal.BasicProfileConfigFileLoader.getProfile(BasicProfileConfigFileLoader.java:55)\n\tat com.amazonaws.retry.internal.RetryModeResolver.profile(RetryModeResolver.java:92)\n\tat com.amazonaws.retry.internal.RetryModeResolver.resolveRetryMode(RetryModeResolver.java:83)\n\tat com.amazonaws.retry.internal.RetryModeResolver.<init>(RetryModeResolver.java:46)\n\tat com.amazonaws.retry.RetryPolicy.<clinit>(RetryPolicy.java:35)\n\tat com.amazonaws.retry.PredefinedRetryPolicies.<clinit>(PredefinedRetryPolicies.java:30)\n\tat com.amazonaws.ClientConfiguration.<clinit>(ClientConfiguration.java:89)\n\tat java.base/java.lang.Class.forName0(Native Method)\n\tat java.base/java.lang.Class.forName(Class.java:383)\n\tat java.base/java.lang.Class.forName(Class.java:376)\n\tat org.elasticsearch.repositories.s3.S3RepositoryPlugin.lambda$static$0(S3RepositoryPlugin.java:59)\n\tat java.base/java.security.AccessController.doPrivileged(AccessController.java:318)\n\tat org.elasticsearch.repositories.s3.S3RepositoryPlugin.<clinit>(S3RepositoryPlugin.java:53)\n\tat java.base/jdk.internal.misc.Unsafe.ensureClassInitialized0(Native Method)\n\tat java.base/jdk.internal.misc.Unsafe.ensureClassInitialized(Unsafe.java:1160)\n\tat java.base/jdk.internal.reflect.MethodHandleAccessorFactory.ensureClassInitialized(MethodHandleAccessorFactory.java:300)\n\tat java.base/jdk.internal.reflect.MethodHandleAccessorFactory.newConstructorAccessor(MethodHandleAccessorFactory.java:103)\n\tat java.base/jdk.internal.reflect.ReflectionFactory.newConstructorAccessor(ReflectionFactory.java:236)\n\tat java.base/java.lang.reflect.Constructor.acquireConstructorAccessor(Constructor.java:546)\n\tat java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:496)\n\tat java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:483)\n\tat org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:757)\n\tat org.elasticsearch.plugins.PluginsService.loadBundle(PluginsService.java:704)\n\tat org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:487)\n\tat org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:165)\n\tat org.elasticsearch.node.Node.<init>(Node.java:393)\n\tat org.elasticsearch.node.Node.<init>(Node.java:291)\n\tat org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:234)\n\tat org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234)\n\tat org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:358)\n\tat org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169)\n\tat org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:160)\n\tat org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:81)\n\tat org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)\n\tat org.elasticsearch.cli.Command.main(Command.java:77)\n\tat org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:125)\n\tat org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80)\n"`

I've tried to find how to fix it and found that it was suppressed in [Hide c.a.a.p.i.BasicProfileConfigFileLoader noise by DaveCTurner · Pull Request #56346 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/pull/56346), but currently it appears again. How can I suppress it again without setting logger.level to `info` or `error`?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [June 20, 2022, 2:45pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/2 "2022-06-20T14:45:15Z")

</div>

Why do you want to set the root logger level to `WARN`? The logs emitted at `INFO` are also usually important. If you want to suppress particular `INFO` messages then you can set a specific logger to `WARN` level, but I'd recommend not adjusting the root logger like this.

---

<div class="post-metadata">

**Author:** ![Anarhyst266](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anarhyst266/32/107268_2.png) [@Anarhyst266](https://discuss.elastic.co/u/Anarhyst266)\
**Post date:** [June 20, 2022, 2:51pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/3 "2022-06-20T14:51:43Z")

</div>

It's because I don't really need most of all 'INFO' logs when cluster is already configured and working. I set 'INFO' for some specific loggers, but for most of loggers I want to have 'WARN' to not store unneeded logs

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [June 20, 2022, 3:42pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/4 "2022-06-20T15:42:53Z")

</div>

Repeating that I think this is a bad idea, there aren't that many `INFO` logs and you will struggle to interpret `WARN` logs without them.

However you should be able to set the `c.a.a.p.i.BasicProfileConfigFileLoader` logger to `ERROR` which will override the root logger level.

---

<div class="post-metadata">

**Author:** ![Anarhyst266](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anarhyst266/32/107268_2.png) [@Anarhyst266](https://discuss.elastic.co/u/Anarhyst266)\
**Post date:** [June 20, 2022, 3:49pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/5 "2022-06-20T15:49:27Z")

</div>

I've tried to set it to error or fatal via log4j2.properties, but that didn't work. Will try again

---

<div class="post-metadata">

**Author:** ![Anarhyst266](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anarhyst266/32/107268_2.png) [@Anarhyst266](https://discuss.elastic.co/u/Anarhyst266)\
**Post date:** [June 21, 2022, 12:41pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/6 "2022-06-21T12:41:08Z")

</div>

I've tried to set logger level to error, but this doesn't work:

```auto
logger.com_amazonaws_auth_profile_internal_BasicProfileConfigFileLoader.name = com.amazonaws.auth.profile.internal.BasicProfileConfigFileLoader
 logger.com_amazonaws_auth_profile_internal_BasicProfileConfigFileLoader.level = error

```

I've also tried to set the whole com.amazoonaws logger level to error, but this doesn't work too:

```auto
logger.com_amazonaws.name = com.amazonaws
logger.com_amazonaws.level = error

```

Do you have any ideas why it doesn't work and how to fix that?

---

<div class="post-metadata">

**Author:** ![Anarhyst266](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anarhyst266/32/107268_2.png) [@Anarhyst266](https://discuss.elastic.co/u/Anarhyst266)\
**Post date:** [June 21, 2022, 5:55pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/7 "2022-06-21T17:55:38Z")

</div>

OK. It was my fault. IDK why, but if setup logger.level env var in dockerized ES it will ignore log4j2.properties(at least in that case). After setting rootLogger level to warn via log4j all works fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 19, 2022, 5:56pm UTC](https://discuss.elastic.co/t/c-a-a-p-i-basicprofileconfigfileloader-noise/307630/8 "2022-07-19T17:56:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
