# Can I reload after a setting change in elasticsearch.yml?

**URL:** <https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565>\
**Category:** Elasticsearch\
**Created:** [May 16, 2023, 12:22pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565 "2023-05-16T12:22:32Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![GenSSC](https://avatars.discourse-cdn.com/v4/letter/g/258eb7/32.png) [@GenSSC](https://discuss.elastic.co/u/GenSSC)\
**Post date:** [May 16, 2023, 12:22pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/1 "2023-05-16T12:22:32Z")

</div>

Is there a way to only reload the settings and not the whole stack ?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 16, 2023, 12:24pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/2 "2023-05-16T12:24:12Z")

</div>

If you have made changes to the Elasticsearch config you will need to restart the node(s) for it to take effect.

---

<div class="post-metadata">

**Author:** ![GenSSC](https://avatars.discourse-cdn.com/v4/letter/g/258eb7/32.png) [@GenSSC](https://discuss.elastic.co/u/GenSSC)\
**Post date:** [May 16, 2023, 12:40pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/3 "2023-05-16T12:40:39Z")

</div>

and if I do it node by node, there won't be any impact on the users right?  
That would also be true for rebooting one master at the time?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 16, 2023, 1:08pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/4 "2023-05-16T13:08:40Z")

</div>

What kind of changes have you made?

---

<div class="post-metadata">

**Author:** ![GenSSC](https://avatars.discourse-cdn.com/v4/letter/g/258eb7/32.png) [@GenSSC](https://discuss.elastic.co/u/GenSSC)\
**Post date:** [May 16, 2023, 1:36pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/5 "2023-05-16T13:36:40Z")

</div>

I removed some deprecated settings that were giving me critical errors in the Upgrade Assistant.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 16, 2023, 1:41pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/6 "2023-05-16T13:41:22Z")

</div>

Then I suspect you should be able to do a rolling restart. If you have changed settings to enable or disable TLS you would have needed to do a full cluster restart.

---

<div class="post-metadata">

**Author:** ![GenSSC](https://avatars.discourse-cdn.com/v4/letter/g/258eb7/32.png) [@GenSSC](https://discuss.elastic.co/u/GenSSC)\
**Post date:** [May 16, 2023, 2:40pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/7 "2023-05-16T14:40:30Z")

</div>

@Christian_Dahlqvist Ok I tried rebooting one of my 3 nodes and Elasticsearch wouldn't start.

I have a critical error about "discovery.zen.ping.unicast.hosts" being deprecated so I commented it in elasticsearch.yml. It didn't like that so I uncommented it and I was able to start the service.

If I don't remove it, I will still have my critical error so that's an issue...

I got this error in the log : bootstrap check failure [1] of [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed\_hosts, discovery.seed\_providers, cluster.initial\_master\_nodes] must be configured

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 13, 2023, 2:40pm UTC](https://discuss.elastic.co/t/can-i-reload-after-a-setting-change-in-elasticsearch-yml/333565/8 "2023-06-13T14:40:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
