# Can not loading adding integrations page. ELK v8.14.0 on Ubuntu

**URL:** <https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474>\
**Category:** Elasticsearch\
**Created:** [June 14, 2024, 8:35am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474 "2024-06-14T08:35:44Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![ahn](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@ahn](https://discuss.elastic.co/u/ahn)\
**Post date:** [June 14, 2024, 8:35am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/1 "2024-06-14T08:35:44Z")

</div>

Hi hero,

Please help a beginner.

## Test environment OS - Ubuntu 22.04.3 LTS ELK version - elasticsearch-8.14.0-linux-x86\_64.tar kibana-8.14.0-linux-x86\_64.tar

I went through two situations.

1. When I installed ELK at home, everything worked fine.
2. When I installed ELK at work, I couldn't check the adding integrations page. It became infinite loading. The company does not have a policy to block access to the Internet.

## My goal is to solve situation number 2. The only thing I want is to see the adding integrations page in Elasticsearch.

## The following is the log that appears when a problem occurs. [ERROR][plugins.fleet] Failed to fetch latest version of synthetics from registry: Error connecting to package registry: request to [https://epr.elastic.co/search?package=synthetics&prerelease=true&kibana.version=8.14.0](https://epr.elastic.co/search?package=synthetics&prerelease=true&kibana.version=8.14.0) failed, reason: self-signed certificate in certificate chain

I did the same thing with the same file worked fine at home, but the problem only occurred at company and I realized it was a self-signed certificate issue.

I already tried to solve it through several ways, but it still didn't work out.  
I am a beginner in Elastic.  
I'd like to solve it as simply as possible.

## Below is the full content of ELK yml file. I changed the .(dot) to \_ for posting purposes.

\<elasticsearch.yml\>  
xpack.security.enabled: true  
xpack.security.enrollment.enabled: true

xpack.security.http.ssl:  
enabled: true  
keystore.path: certs/http.p12

xpack.security.transport.ssl:  
enabled: true  
verification\_mode: certificate  
keystore.path: certs/transport.p12  
truststore.path: certs/transport.p12

cluster.initial\_master\_nodes: ["ABCD-1234"]

http\_host: 0\_0\_0\_0

* * *

\<kibana.yml\>  
elasticsearch.hosts: ['https://192\_168\_254\_1:9200']  
elasticsearch.serviceAccountToken: AAEAAWVsYXN0aWMva2liYW5hL2Vucm9sbC1wcm9jZXNzLXRva2VuLTE3MTgyNjY1Nzk3MDA6Y0xyT1FuZmlSeDI0aTV2N01nUzV6UQ  
elasticsearch.ssl.certificateAuthorities: [/home/es/kibana-8.14.0/data/ca\_1718266580760.crt]  
xpack.fleet.outputs: [{id: fleet-default-output, name: default, is\_default: true, is\_default\_monitoring: true, type: elasticsearch, hosts: ['https://192\_168\_254\_1:9200'], ca\_trusted\_fingerprint: 45aec6230a34ea6fa052c4ef9ba4586171265753e858f9e7180ab930aab0c4dd}]

* * *

## This is the connection address I use when connecting via ELK. [http://localhost:5601](http://localhost:5601)

I want to solve it in the simplest way possible, whether to use a certificate or not.

If you have more questions or more information, please let me know.  
Thanks in advance.

Regards  
-Ahn-

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [June 18, 2024, 8:42am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/2 "2024-06-18T08:42:35Z")

</div>

Hi @ahn,

Welcome! Is it Elasticsearch 8.14 that you've tried to instlal both at home and at work? Do you see any errors in the logs or the Chrome DevTools console?

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [June 18, 2024, 12:34pm UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/3 "2024-06-18T12:34:23Z")

</div>

> [@ahn](#):
>
> I did the same thing with the same file worked fine at home, but the problem only occurred at company and I realized it was a self-signed certificate issue.

I don't think there is any issue in any elastic tool, it seems an issue on the network you have at your company.

Your company may not be blocking access to the internet, but it may be using a proxy or doing ssl inspection.

You need to check it, I would say that probably there is something like SSL inspection being done.

---

<div class="post-metadata">

**Author:** ![ahn](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@ahn](https://discuss.elastic.co/u/ahn)\
**Post date:** [June 19, 2024, 1:12am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/4 "2024-06-19T01:12:01Z")

</div>

Welcome! Is it Elasticsearch 8.14 that you've tried to instlal both at home and at work?

## -\> Yes, both 8.14

Do you see any errors in the logs or the Chrome DevTools console?

## -\> As in the text, this is the error log. [ERROR][plugins.fleet] Failed to fetch latest version of synthetics from registry: Error connecting to package registry: request to [https://epr.elastic.co/search?package=synthetics&prerelease=true&kibana.version=8.14.0](https://epr.elastic.co/search?package=synthetics&prerelease=true&kibana.version=8.14.0) failed, reason: self-signed certificate in certificate chain

Thank you.

---

<div class="post-metadata">

**Author:** ![ahn](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@ahn](https://discuss.elastic.co/u/ahn)\
**Post date:** [June 19, 2024, 1:13am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/5 "2024-06-19T01:13:48Z")

</div>

You're right. I think it's 100% a certificate issue. Is there any way I can solve this problem on my own?  
Thank you.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [June 19, 2024, 8:37am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/6 "2024-06-19T08:37:12Z")

</div>

How are you running Elasticsearch? Are you using Docker? You might need to specify the root certificate [as discussed in this thread](https://discuss.elastic.co/t/kibana-fleet-shows-self-signed-certificate-in-certificate-chain/297947).

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [June 19, 2024, 12:08pm UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/7 "2024-06-19T12:08:49Z")

</div>

> [@ahn](#):
>
> Is there any way I can solve this problem on my own?

I don't think so, as mentioned it seems to be a network issue, so you need to check internally in your company who manages the network and ask for help to troubleshoot this issue.

---

<div class="post-metadata">

**Author:** ![ahn](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@ahn](https://discuss.elastic.co/u/ahn)\
**Post date:** [June 20, 2024, 7:49am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/8 "2024-06-20T07:49:19Z")

</div>

Hi, leandrojmp  
OK I will ask security manager.  
Thank you very much.  
Regards  
-Ahn

---

<div class="post-metadata">

**Author:** ![ahn](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@ahn](https://discuss.elastic.co/u/ahn)\
**Post date:** [June 20, 2024, 7:50am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474/9 "2024-06-20T07:50:45Z")

</div>

Hi carly.richmond,  
It's not Docker-based.  
OK I will ask security manager.  
Thank you very much.  
Regards  
-Ahn
