# Can not set up beats along with logstash

**URL:** <https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562>\
**Category:** Logstash\
**Created:** [December 19, 2018, 4:50pm UTC](https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562 "2018-12-19T16:50:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bertolis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bertolis/32/35522_2.png) [@bertolis](https://discuss.elastic.co/u/bertolis)\
**Post date:** [December 19, 2018, 4:50pm UTC](https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562/1 "2018-12-19T16:50:39Z")

</div>

Hi, i am trying to configure beats working with logstash, using docker compose. If i don't use logstash then everything works perfectly in kibana's dashboard, but when i use logstash and i open kibana, i get some errors and some visualizations can not be displayed. Here are some of my configurations:

logstash.conf

```auto
input {
    beats {
        port => 5044
    }
}

output {
    elasticsearch {
        hosts => "elasticsearch:9200"
        index => "%{[@metadata][beat]}-%{[@metadata][version]}"
    }
}

```

metricbeat.yml

```auto
#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["192.168.1.1:5044"]

```

Thanks.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 19, 2018, 9:32pm UTC](https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562/2 "2018-12-19T21:32:34Z")

</div>

> [@bertolis](#):
>
> get some errors

Sharing those errors would be helpful 🙂

---

<div class="post-metadata">

**Author:** ![bertolis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bertolis/32/35522_2.png) [@bertolis](https://discuss.elastic.co/u/bertolis)\
**Post date:** [January 7, 2019, 10:17am UTC](https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562/4 "2019-01-07T10:17:37Z")

</div>

These errors occurred in kibana. For example on metricbeat i get the following:

```auto
The request for this panel failed.
Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order
to load fielddata in memory by uninverting the inverted index.
Note that this can however use significant memory. Alternatively use a keyword field instead.

```

```auto
Saved "field" parameter is now invalid. Please select a new field.

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 4, 2019, 10:17am UTC](https://discuss.elastic.co/t/can-not-set-up-beats-along-with-logstash/161562/5 "2019-02-04T10:17:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
