# Can not Start Elasticsearch on CentOS 7

**URL:** https://discuss.elastic.co/t/can-not-start-elasticsearch-on-centos-7/139749
**Category:** Elasticsearch
**Created:** [July 12, 2018, 12:21pm UTC](https://discuss.elastic.co/t/can-not-start-elasticsearch-on-centos-7/139749 "2018-07-12T12:21:42Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![leandro\_matos\_pereir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandro_matos_pereir/32/65342_2.png) [@leandro\_matos\_pereir](https://discuss.elastic.co/u/leandro_matos_pereir)
#### Post date: [July 12, 2018, 12:21pm UTC](https://discuss.elastic.co/t/can-not-start-elasticsearch-on-centos-7/139749/1 "2018-07-12T12:21:43Z")

</div>

I'm a beginner with elastic search, the same was put into production was with Kibana, search was working but due to some update its stop working and giving this error message while checking status.

![image](https://us1.discourse-cdn.com/elastic/original/3X/6/d/6dc4ee74b8f994c63fe417ddee74d110236a1e61.png)

========================================================================  
service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Thu 2018-07-12 08:53:06 -03; 25min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2898 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 2898 (code=exited, status=1/FAILURE)

Jul 12 08:53:06 a6-zwatcher1 systemd[1]: Started Elasticsearch.  
Jul 12 08:53:06 a6-zwatcher1 systemd[1]: Starting Elasticsearch...  
Jul 12 08:53:06 a6-zwatcher1 elasticsearch[2898]: which: no java in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin)  
Jul 12 08:53:06 a6-zwatcher1 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Jul 12 08:53:06 a6-zwatcher1 systemd[1]: Unit elasticsearch.service entered failed state.  
Jul 12 08:53:06 a6-zwatcher1 systemd[1]: elasticsearch.service failed.

========================================================================  
Log file:

tail -f elasticsearch.log  
[2018-07-11T17:16:55,023][INFO][o.e.c.r.a.DiskThresholdMonitor] [tef-elk-01] rerouting shards: [high disk watermark exceeded on one or more nodes]  
[2018-07-11T17:17:25,740][WARN][o.e.c.r.a.DiskThresholdMonitor] [tef-elk-01] high disk watermark [90%] exceeded on [UuMB8U6dSGCJ3BUujtbFHQ][tef-elk-02][/export/elasticsearch/data/nodes/0] free: 22.6gb[9.2%], shards will be relocated away from this node  
[2018-07-11T17:17:55,875][WARN][o.e.c.r.a.DiskThresholdMonitor] [tef-elk-01] high disk watermark [90%] exceeded on [UuMB8U6dSGCJ3BUujtbFHQ][tef-elk-02][/export/elasticsearch/data/nodes/0] free: 22.6gb[9.2%], shards will be relocated away from this node  
[2018-07-11T17:17:55,875][INFO][o.e.c.r.a.DiskThresholdMonitor] [tef-elk-01] rerouting shards: [high disk watermark exceeded on one or more nodes]  
[2018-07-11T17:18:26,341][WARN][o.e.c.r.a.DiskThresholdMonitor] [tef-elk-01] high disk watermark [90%] exceeded on [UuMB8U6dSGCJ3BUujtbFHQ][tef-elk-02][/export/elasticsearch/data/nodes/0] free: 22.6gb[9.2%], shards will be relocated away from this node

However the same is not with the full partition:

df -h /var/opt/UOLI/elasticsearch/data  
Filesystem Size Used Avail Use% Mounted on  
server-2c-trk1:/uolps\_tefelasticsearch\_0 247G 224G 23G 91% /var/opt/UOLI/elasticsearch/data

---

<div class="post-metadata">

### Author: ![d-niet123](https://avatars.discourse-cdn.com/v4/letter/d/9d8465/32.png) [@d-niet123](https://discuss.elastic.co/u/d-niet123)
#### Post date: [July 12, 2018, 6:13pm UTC](https://discuss.elastic.co/t/can-not-start-elasticsearch-on-centos-7/139749/2 "2018-07-12T18:13:33Z")

</div>

It looks like the user account trying to start Elasticsearch doesn't have java installed or doesn't know where Java is installed. Can you verify if java is installed and where its installed at?

As for whats in the log file, Elasticsearch avoids allocating shards to nodes that have more than 85% disk usage. [https://www.elastic.co/guide/en/elasticsearch/reference/current/disk-allocator.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/disk-allocator.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 9, 2018, 6:13pm UTC](https://discuss.elastic.co/t/can-not-start-elasticsearch-on-centos-7/139749/3 "2018-08-09T18:13:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
