# Cannot able to send data from Jaeger to Elastic APM with APM secret token

**URL:** https://discuss.elastic.co/t/cannot-able-to-send-data-from-jaeger-to-elastic-apm-with-apm-secret-token/313808
**Category:** APM
**Tags:** dotnet
**Created:** [September 6, 2022, 3:08pm UTC](https://discuss.elastic.co/t/cannot-able-to-send-data-from-jaeger-to-elastic-apm-with-apm-secret-token/313808 "2022-09-06T15:08:01Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![venkatkumar229](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/venkatkumar229/32/104663_2.png) [@venkatkumar229](https://discuss.elastic.co/u/venkatkumar229)
#### Post date: [September 6, 2022, 3:08pm UTC](https://discuss.elastic.co/t/cannot-able-to-send-data-from-jaeger-to-elastic-apm-with-apm-secret-token/313808/1 "2022-09-06T15:08:01Z")

</div>

Hi Team,

We are trying to send the data from jaeger to Elastic APM using the jaeger agent.

We are trying as per the elastic documentation. We are using below config.

```auto
args:
  - --reporter.grpc.host-port=<apm-endpoint:8200>
  - --reporter.grpc.tls.enabled=true
  - --agent.tags="elastic-apm-auth=Bearer <secret-token>"

```

We are getting an error while running jaeger.

"msg":"Could not send spans over gRPC","error":"rpc error: code = Unauthenticated desc = authentication failed: missing or improperly formatted Authorization header: expected 'Authorization: Bearer secret\_token' or 'Authorization: ApiKey base64(API key ID:API key)'"

Could you please hep us with this.

---

<div class="post-metadata">

### Author: ![venkatkumar229](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/venkatkumar229/32/104663_2.png) [@venkatkumar229](https://discuss.elastic.co/u/venkatkumar229)
#### Post date: [September 6, 2022, 5:42pm UTC](https://discuss.elastic.co/t/cannot-able-to-send-data-from-jaeger-to-elastic-apm-with-apm-secret-token/313808/2 "2022-09-06T17:42:32Z")

</div>

Solved by changing agent.tags with jaeger.tags.

```auto
args:
  - --reporter.grpc.host-port=<apm-endpoint:8200>
  - --reporter.grpc.tls.enabled=true
  - --jaeger.tags=elastic-apm-auth=Bearer <secret-token>

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 27, 2022, 1:42pm UTC](https://discuss.elastic.co/t/cannot-able-to-send-data-from-jaeger-to-elastic-apm-with-apm-secret-token/313808/3 "2022-09-27T13:42:44Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
