# Cannot access Elasticsearch outside

**URL:** https://discuss.elastic.co/t/cannot-access-elasticsearch-outside/383153
**Category:** Elasticsearch
**Created:** [November 1, 2025, 4:10pm UTC](https://discuss.elastic.co/t/cannot-access-elasticsearch-outside/383153 "2025-11-01T16:10:50Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [November 2, 2025, 2:06am UTC](https://discuss.elastic.co/t/cannot-access-elasticsearch-outside/383153/2 "2025-11-02T02:06:35Z")

</div>

@Peter_Penzov Welcome to the community.

> [@Peter\_Penzov](#):
>
> ```auto
> curl -k --user elastic:zzzzzzz -X GET "https://193.1z.z.z:9200"
> curl: (7) Failed to connect to 193.1z.z.z port 9200: No route to host
> 
> ```

I am not familiar with the specifics of OCI but often / on other CSPs you will need to do some work to map the external IP and / or adjust the FW Rules.

This is most likely an OCI / Neworking issue not an Elastic Issue.

I think if you put "OCI no route to host" into your favorite search engine you will get some results

example

[https://community.oracle.com/customerconnect/discussion/668425/new-ubuntu-instance-gets-error-no-route-to-host-for-hosts-on-external-networks](https://community.oracle.com/customerconnect/discussion/668425/new-ubuntu-instance-gets-error-no-route-to-host-for-hosts-on-external-networks)

In additopm please look closely at the Advice that was given to you here:

> [@ElasticSearch IPv6](https://discuss.elastic.co/t/elasticsearch-ipv6/383150/2):
>
> Somewhat confusingly tcp6 refers to the mixed IPv4 and IPv6 stack, as you can see from this line which has an IPv4 address: tcp6 0 0 10.0.0.12:9300 :::\* LISTEN 1040/java This line means it’s listening on all interfaces: tcp6 0 0 :::9200 :::\* LISTEN 1040/java Please read [these docs](https://www.elastic.co/docs/reference/elasticsearch/configuration-reference/networking-settings#modules-network-binding-publishing) carefully for further information, noting in particular: It is usually a mistake to use 0.0.0.0 as a publish addr…

Also Please try not not open multiple topics on the same question.

---

_[View the full topic](https://discuss.elastic.co/t/cannot-access-elasticsearch-outside/383153)._
