# Cannot access Pet Clinic application in the Strigo Lab

**URL:** <https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600>\
**Category:** Elastic Training\
**Created:** [September 3, 2022, 12:50pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600 "2022-09-03T12:50:12Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![timmo](https://avatars.discourse-cdn.com/v4/letter/t/34f0e0/32.png) [@timmo](https://discuss.elastic.co/u/timmo)\
**Post date:** [September 3, 2022, 12:50pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/1 "2022-09-03T12:50:12Z")

</div>

Hi,

I have started taking the Elasticsearch Observability Engineer (On-Demand) course. I managed to reach lab 3.3 (Collecting APM data) and suddenly cannot access Pet Clinic application.

How can I restart the Pet Clinic application? Any idea will be appreciated. Thanks

---

<div class="post-metadata">

**Author:** ![Romain\_Geffraye](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/romain_geffraye/32/77053_2.png) [@Romain\_Geffraye](https://discuss.elastic.co/u/Romain_Geffraye)\
**Post date:** [September 5, 2022, 8:40pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/2 "2022-09-05T20:40:19Z")

</div>

Hello!

You might want to check the logs of the application’s container to see what went wrong.

Maybe you updated some configuration and the app cannot restart?

The logs will help us answer that question 😀

Romain

---

<div class="post-metadata">

**Author:** ![timmo](https://avatars.discourse-cdn.com/v4/letter/t/34f0e0/32.png) [@timmo](https://discuss.elastic.co/u/timmo)\
**Post date:** [September 6, 2022, 5:32am UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/3 "2022-09-06T05:32:51Z")

</div>

Thanks @Romain_Geffraye

This is what I see in the logs:-

```auto
APM Server transport error (ECONNREFUSED): connect ECONNREFUSED 127.0.0.1:8200
Sending error to Elastic APM { id: 'cfcb4183094aa872fb417ecc8870dd69' }
APM Server transport error (ECONNREFUSED): connect ECONNREFUSED 127.0.0.1:8200

```

I have installed elastic-apm-node, details below:-

```auto
elastic-apm-node@3.38.0 | BSD-2-Clause | deps: 32 | versions: 125
The official Elastic APM agent for Node.js
https://github.com/elastic/apm-agent-nodejs

keywords: opbeat, elastic, elasticapm, elasticsearch, log, logging, bug, bugs, error, errors, exception, exceptions, catch, monitor, monitoring, alert, alerts, performance, apm, ops, devops, stacktrace, trace, tracing, distributedtracing, distributed-tracing

dist
.tarball: https://registry.npmjs.org/elastic-apm-node/-/elastic-apm-node-3.38.0.tgz
.shasum: 4d0dc9279c0e23e09b3b30aa4a9f9aeccfa59cc0
.integrity: sha512-/d6YuWFtsfkVRpFD0YJ2rYJVq0rI0PGqG/C+cW1JpMZ4IOU8dA9xzUkxbT0G3B8gpHNug07Xo6bJdQa2oUaFbQ==
.unpackedSize: 589.9 kB

dependencies:
@elastic/ecs-pino-format: ^1.2.0 async-value-promise: ^1.1.1 elastic-apm-http-client: 11.0.1 escape-string-regexp: ^4.0.0 lru-cache: ^6.0.0 object-identity-map: ^1.0.2      
@opentelemetry/api: ^1.1.0 basic-auth: ^2.0.1 end-of-stream: ^1.4.4 fast-safe-stringify: ^2.0.7 measured-reporting: ^1.51.1 original-url: ^1.2.3             
after-all-results: ^2.0.0 cookie: ^0.5.0 error-callsites: ^2.0.4 http-headers: ^3.0.2 monitor-event-loop-delay: ^1.0.0 pino: ^6.11.2                    
async-cache: ^1.1.0 core-util-is: ^1.0.2 error-stack-parser: ^2.0.6 is-native: ^1.0.1 object-filter-sequence: ^1.0.0 relative-microtime: ^2.0.0       
(...and 8 more.)

maintainers:
- trentm <trentm@gmail.com>
- watson <w@tson.dk>
- elasticmachine <infra-root+npm@elastic.co>
- alanstorm <astorm@alanstorm.com>

dist-tags:
2x: 2.17.3 latest: 3.38.0  

```

Configuration looks ok

---

<div class="post-metadata">

**Author:** ![Romain\_Geffraye](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/romain_geffraye/32/77053_2.png) [@Romain\_Geffraye](https://discuss.elastic.co/u/Romain_Geffraye)\
**Post date:** [September 6, 2022, 8:53am UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/4 "2022-09-06T08:53:05Z")

</div>

The configuration looks good.

However, the logs tell you that your application can't connect to the APM server.

Check if your agent is correctly running and if the integration is correctly setup (lab 3.1)

---

<div class="post-metadata">

**Author:** ![timmo](https://avatars.discourse-cdn.com/v4/letter/t/34f0e0/32.png) [@timmo](https://discuss.elastic.co/u/timmo)\
**Post date:** [September 12, 2022, 5:44pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/5 "2022-09-12T17:44:20Z")

</div>

Integration is configured correctly and cant find the problem with the agent.

Is it possible to reset the lab and start from the beginning?

Hope that would help to keep track and eventually understand the root cause.

Thanks

---

<div class="post-metadata">

**Author:** ![Andre\_Murbach\_Maidl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andre_murbach_maidl/32/83508_2.png) [@Andre\_Murbach\_Maidl](https://discuss.elastic.co/u/Andre_Murbach_Maidl)\
**Post date:** [September 12, 2022, 8:27pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/6 "2022-09-12T20:27:44Z")

</div>

Hi @timmo ,

I replaced your lab, so you can restart from the beginning.

Best,  
Andre

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 12, 2022, 8:28pm UTC](https://discuss.elastic.co/t/cannot-access-pet-clinic-application-in-the-strigo-lab/313600/7 "2022-10-12T20:28:42Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
