# Cannot create any visualization

**URL:** <https://discuss.elastic.co/t/cannot-create-any-visualization/89620>\
**Category:** Kibana\
**Created:** [June 15, 2017, 7:32pm UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620 "2017-06-15T19:32:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![namankhator](https://avatars.discourse-cdn.com/v4/letter/n/c89c15/32.png) [@namankhator](https://discuss.elastic.co/u/namankhator)\
**Post date:** [June 15, 2017, 7:32pm UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620/1 "2017-06-15T19:32:41Z")

</div>

Every time I get this error:

```auto
No Compatible Fields: The "sample" index pattern does not contain any of the following field types: number, boolean, date, ip or string

```

This is my index.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/0/5/052aee5b9a7d12c9b4e74500363a3ffc9fa3f5b5.png)  
Also, whenever I run:

```auto
curl 'localhost:9200/_cat/shards?h=index,shard,prirep,state,unassigned.reason'

```

Gives:

```auto
sample 1 p STARTED    
sample 1 r UNASSIGNED CLUSTER_RECOVERED
sample 4 p STARTED    
sample 4 r UNASSIGNED CLUSTER_RECOVERED
sample 3 p STARTED    
sample 3 r UNASSIGNED CLUSTER_RECOVERED
sample 2 p STARTED    
sample 2 r UNASSIGNED CLUSTER_RECOVERED
sample 0 p STARTED    
sample 0 r UNASSIGNED CLUSTER_RECOVERED
.kibana 0 p STARTED    
.kibana 0 r UNASSIGNED INDEX_CREATED

```

I have no idea what to do. I just started with ELK.  
I have elasticsearch 5.4.1  
Kibana 5.4  
Please help ☹

---

<div class="post-metadata">

**Author:** ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)\
**Post date:** [June 15, 2017, 9:22pm UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620/2 "2017-06-15T21:22:34Z")

</div>

Fields aren't showing up in Visualize because none of your fields are listed as `aggregatable`. This might occur if you created the index pattern prior to adding any data to elasticsearch (could happen if you're using the sample beats dashboards). If you have data indexed now, could you try refreshing your field list (click the refresh button on that index pattern page).

If refreshing your field list doesn't fix the problem, do you see any errors in your ES or kibana logs when clicking that refresh button?

---

<div class="post-metadata">

**Author:** ![namankhator](https://avatars.discourse-cdn.com/v4/letter/n/c89c15/32.png) [@namankhator](https://discuss.elastic.co/u/namankhator)\
**Post date:** [June 16, 2017, 3:12am UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620/3 "2017-06-16T03:12:22Z")

</div>

I tried refreshing it, it gives error:

```auto
Field Capabilities: 5 of 5 shards failed

```

This is the error I get on the kibana dashboard.  
Where do I check the logs?

---

<div class="post-metadata">

**Author:** ![namankhator](https://avatars.discourse-cdn.com/v4/letter/n/c89c15/32.png) [@namankhator](https://discuss.elastic.co/u/namankhator)\
**Post date:** [June 16, 2017, 8:04am UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620/4 "2017-06-16T08:04:39Z")

</div>

Done!  
I had to delete my index and start from scratch.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 14, 2017, 8:05am UTC](https://discuss.elastic.co/t/cannot-create-any-visualization/89620/5 "2017-07-14T08:05:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
