# Cannot create APM watcher email error report

**URL:** <https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537>\
**Category:** APM\
**Tags:** ui\
**Created:** [December 19, 2019, 5:58pm UTC](https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537 "2019-12-19T17:58:50Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matthew\_Petrie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_petrie/32/59145_2.png) [@Matthew\_Petrie](https://discuss.elastic.co/u/Matthew_Petrie)\
**Post date:** [December 19, 2019, 5:58pm UTC](https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537/1 "2019-12-19T17:58:50Z")

</div>

**Kibana version** : 7.5.0  
**Elasticsearch version** : 7.5.0  
**APM Server version** : 7.5.0  
**Browser version** : Google Chrome 78.0.3904.108  
**Original install method** : Elastic Cloud  
**Fresh install or upgraded from other version?** Fresh

**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**:

As a superuser I expect to be able to use the Watcher error reports integration to send an email to my email address. Instead I receive the error

![Screenshot 2019-12-19 at 17.51.04](https://us1.discourse-cdn.com/elastic/original/3X/1/8/186b1c00342f9959791fd11f731a637bc542b0d0.png)

The odd thing is that within the Kibana management I can create Watchers that send emails to this same email address with no issues. My user has the `superuser` role. I have also tried adding every possible role to my user but this (as I expected as I had the superuser role) didn't change anything.

**Steps to reproduce** :

1. open `Kibana`
2. navigate to `APM`
3. Click on a service to go to their service specific dashboard
4. open the `integrations` dropdown (towards the top)
5. click `Enable watcher error reports`.
6. enable `Send email` to any email address

---

<div class="post-metadata">

**Author:** ![Edgar\_Peixoto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/edgar_peixoto/32/58987_2.png) [@Edgar\_Peixoto](https://discuss.elastic.co/u/Edgar_Peixoto)\
**Post date:** [December 24, 2019, 4:08pm UTC](https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537/2 "2019-12-24T16:08:20Z")

</div>

Upgrade everything to 7.5.1 and try again. It worked here.

---

<div class="post-metadata">

**Author:** ![Matthew\_Petrie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_petrie/32/59145_2.png) [@Matthew\_Petrie](https://discuss.elastic.co/u/Matthew_Petrie)\
**Post date:** [December 30, 2019, 1:11pm UTC](https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537/3 "2019-12-30T13:11:30Z")

</div>

Thanks Edgar, v7.5.1 resolved this issue 👍

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 20, 2020, 9:19am UTC](https://discuss.elastic.co/t/cannot-create-apm-watcher-email-error-report/212537/4 "2020-01-20T09:19:32Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
