# Cannot Edit Monitor

**URL:** <https://discuss.elastic.co/t/cannot-edit-monitor/384846>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [February 2, 2026, 8:05am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846 "2026-02-02T08:05:47Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![lomar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lomar/32/145141_2.png) [@lomar](https://discuss.elastic.co/u/lomar)\
**Post date:** [February 2, 2026, 8:05am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846/1 "2026-02-02T08:05:47Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/b/9/b910669c8f22f5800b39bc77924ae88eb92decb9.png)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/e/7ebbe2a0b6285baf3b7d446c21879dccd1a67367.jpeg)

When I try to delete via the Elasticsearch API, I get the same error code. I would appreciate your help.

ELK Stack version: 9.2.4

Cluster status: green

---

<div class="post-metadata">

**Author:** ![Musab\_Dogan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/musab_dogan/32/70691_2.png) [@Musab\_Dogan](https://discuss.elastic.co/u/Musab_Dogan)\
**Post date:** [February 2, 2026, 9:37am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846/2 "2026-02-02T09:37:06Z")

</div>

Can you share the error logs?

---

<div class="post-metadata">

**Author:** ![lomar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lomar/32/145141_2.png) [@lomar](https://discuss.elastic.co/u/lomar)\
**Post date:** [February 2, 2026, 10:01am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846/3 "2026-02-02T10:01:33Z")

</div>

When I tried to edit the monitor, nothing was written in the Elasticsearch logs, but the Kibana logs displayed the following error:

```ndjson
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"9.0.0"},"@timestamp":"2026-02-02T12:59:17.682+03:00","message":"Failed to decrypt attribute \"secrets\" of saved object \"synthetics-monitor,b498e77d-9194-425c-a78f-bd2250cc3fd2\": Unsupported state or unable to authenticate data","log":{"level":"ERROR","logger":"plugins.encryptedSavedObjects"},"process":{"pid":724,"uptime":15556.299898569},"trace":{"id":"a19a0c7fdaa3dc1449509cc49e510b07"},"transaction":{"id":"f0862617914906cf"}}

```

---

<div class="post-metadata">

**Author:** ![lomar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lomar/32/145141_2.png) [@lomar](https://discuss.elastic.co/u/lomar)\
**Post date:** [February 2, 2026, 11:44am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846/4 "2026-02-02T11:44:25Z")

</div>

I've solved the problem by deleting monitors using following enpoint:

```auto
DELETE .kibana/_doc/synthetics-monitor:<monitor-id>

```

the must has `kibana_system` role

---

<div class="post-metadata">

**Author:** ![Musab\_Dogan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/musab_dogan/32/70691_2.png) [@Musab\_Dogan](https://discuss.elastic.co/u/Musab_Dogan)\
**Post date:** [February 2, 2026, 11:51am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846/5 "2026-02-02T11:51:06Z")

</div>

well done. Happy to hear the issue is solved.
