# Cannot get cross-cluster search to work

**URL:** <https://discuss.elastic.co/t/cannot-get-cross-cluster-search-to-work/90361>\
**Category:** Elasticsearch\
**Created:** [June 21, 2017, 8:59pm UTC](https://discuss.elastic.co/t/cannot-get-cross-cluster-search-to-work/90361 "2017-06-21T20:59:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![afederici](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/afederici/32/19392_2.png) [@afederici](https://discuss.elastic.co/u/afederici)\
**Post date:** [June 21, 2017, 8:59pm UTC](https://discuss.elastic.co/t/cannot-get-cross-cluster-search-to-work/90361/1 "2017-06-21T20:59:57Z")

</div>

Hi,  
I just downloaded and installed ES 5.4.2 on my Windows 10 machine to try the cross-cluster search feature. Unfortunately I cannot seem to get it working. Whenever I try to send a query to the "remote" cluster (post /cluster\_one:index1/Person/\_search) I get back this:

{  
"error": {  
"root\_cause": [],  
"type": "search\_phase\_execution\_exception",  
"reason": "all shards failed",  
"phase": "query",  
"grouped": true,  
"failed\_shards": []  
},  
"status": 503  
}

My second ES never receives the query and nothing gets logged. I instead see logs from the first ES and it seems it is not recognizing

My setup: I have 2 instances of ES running on the same machine. The first (which I refer to as 'local') uses ports http:9400 and tcp:9500. The second ('cluster\_one') is setup to use http:9600 and tcp:9700. Both instances work great and they respond using 127.0.0.1, localhost or the name of the machine itself.

I setup the "link" to the second instance from the first, using almost the same JSON in the documentation. The latest version of my JSON is this:

PUT \_cluster/settings  
{  
"persistent": {  
"search": {  
"remote": {  
"cluster\_one": {  
"seeds": [  
"127.0.0.1:9700"  
]  
}  
}  
}  
}  
}

get \_cluster/settings returns this:  
{  
"persistent": {  
"search": {  
"remote": {  
"cluster\_one": {  
"seeds": [  
"127.0.0.1:9700"  
]  
}  
}  
}  
},  
"transient": {}  
}

I then tried to search by using this JSON:

post /cluster\_one:index1/Person/\_search  
{  
"query": {  
"match\_all": {}  
}  
}

but ES returns the error I pasted at the beginning.  
The query works just fine on the second ES instance (e.g. post /index1/Person/\_search) directly.

Interesting things I noticed:  
-If I add a setting to link ES-1 to itself (like in the docs) and I try to query it, everything works. What doesn't work is accessing a different cluster.  
-I tried to change the settings setting 'seeds' to 'null' but that doesn't work. I finally managed to remove the setting using this (notice '[null]', instead of 'null'):

PUT \_cluster/settings  
{  
"persistent": {  
"search": {  
"remote": {  
"cluster\_one": {  
"seeds": [null]  
}  
}  
}  
}  
}

I am fairly stuck right now and don't know how to proceed.  
I hope I provided enough information.

Thanks,  
Alessandro

---

<div class="post-metadata">

**Author:** ![afederici](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/afederici/32/19392_2.png) [@afederici](https://discuss.elastic.co/u/afederici)\
**Post date:** [July 5, 2017, 1:14pm UTC](https://discuss.elastic.co/t/cannot-get-cross-cluster-search-to-work/90361/2 "2017-07-05T13:14:36Z")

</div>

Anybody?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 2, 2017, 1:15pm UTC](https://discuss.elastic.co/t/cannot-get-cross-cluster-search-to-work/90361/3 "2017-08-02T13:15:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
