# Cannot get dashboard/visualizations to load

**URL:** <https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434>\
**Category:** Kibana\
**Created:** [November 5, 2018, 4:50pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434 "2018-11-05T16:50:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![njmauch](https://avatars.discourse-cdn.com/v4/letter/n/4bbf92/32.png) [@njmauch](https://discuss.elastic.co/u/njmauch)\
**Post date:** [November 5, 2018, 4:50pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434/1 "2018-11-05T16:50:07Z")

</div>

HI,

I have been trying to get my kibana dashboards/visualizations to load for some time now and seem to be running out of options. I have information flowing over and I can see the index. I created the index "filebeat-\*" and then attempt to view it in a dashboard or visualization and it tells me

Could not locate that index-pattern (id: filebeat-\*), [click here to re-create it](http://localhost:5601/app/kibana#/management/kibana/index)

Still fairly new at using ELK so what ever info is needed please let me know.

---

<div class="post-metadata">

**Author:** ![Aaron\_Caldwell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron_caldwell/32/45755_2.png) [@Aaron\_Caldwell](https://discuss.elastic.co/u/Aaron_Caldwell)\
**Post date:** [November 5, 2018, 5:06pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434/2 "2018-11-05T17:06:17Z")

</div>

Hello Nathan,

Assuming you've created the index-pattern, that is a strange error. I'm not sure which version of ES you're running, but I did come across an issue which resulted in a bug report here:

> [@Frustrating error: Could not locate that index-pattern (id: false), click here to re-create it](https://discuss.elastic.co/t/frustrating-error-could-not-locate-that-index-pattern-id-false-click-here-to-re-create-it/141911/8):
>
> Managed to reproduce the issue locally, thanks for following up. Will investigate to see what the root cause of it and create an issue for it.

If your version is different or the details there don't quite sync up, I also came across this thread which identifies some good debugging steps:

> [@Dashboard error: Could not locate that index-pattern although it exists](https://discuss.elastic.co/t/dashboard-error-could-not-locate-that-index-pattern-although-it-exists/112876):
>
> Running ES 6.0 with Kibana and Metricbeat of the same version I'm getting Could not locate that index-pattern (id: metricbeat-\*), click here to re-create it in the Metricbeat Host dashboard. This only happens for the Number of processes visualization, the rest shows up fine. Editing this vis I can see this message and search: There is a problem with this saved object The index pattern associated with this object no longer exists. If you know what this error means, go ahead and fix it — otherw…

Regards,  
Aaron

---

<div class="post-metadata">

**Author:** ![njmauch](https://avatars.discourse-cdn.com/v4/letter/n/4bbf92/32.png) [@njmauch](https://discuss.elastic.co/u/njmauch)\
**Post date:** [November 7, 2018, 5:06pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434/3 "2018-11-07T17:06:12Z")

</div>

Hi Aaron,

Thank you for the response and was looking at the article "Dashboard error:" I am trying to follow along, and see the part about the id and the guid for the index pattern. I have gone into advanced settings trying to update it but not sure what exactly to be updating. I am using filebeat, logstash, elasticsearch, and kibana all version 6.4.0

---

<div class="post-metadata">

**Author:** ![njmauch](https://avatars.discourse-cdn.com/v4/letter/n/4bbf92/32.png) [@njmauch](https://discuss.elastic.co/u/njmauch)\
**Post date:** [November 8, 2018, 5:50pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434/4 "2018-11-08T17:50:26Z")

</div>

I was able to get it figured out, I changed the index under kibanaSavedObjectMeta.searchSourceJSON to the guid of the index, found in advanced settings, rather than the name of the index such as filebeat-\* and got it to work

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 6, 2018, 5:50pm UTC](https://discuss.elastic.co/t/cannot-get-dashboard-visualizations-to-load/155434/5 "2018-12-06T17:50:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
