# Cannot get multiline config correct in 6.5.1

**URL:** <https://discuss.elastic.co/t/cannot-get-multiline-config-correct-in-6-5-1/160682>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 13, 2018, 7:50am UTC](https://discuss.elastic.co/t/cannot-get-multiline-config-correct-in-6-5-1/160682 "2018-12-13T07:50:15Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pappaola](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@pappaola](https://discuss.elastic.co/u/pappaola)\
**Post date:** [December 13, 2018, 7:50am UTC](https://discuss.elastic.co/t/cannot-get-multiline-config-correct-in-6-5-1/160682/1 "2018-12-13T07:50:16Z")

</div>

I have tried to install 6.5.1 on a windows machine, before I was running 6.1.2. Everything has gone alright except the multiline config for my filebeat (6.5.1 win\_x86).

I tried using the "same" config (there are some minor differences (eg. filebeat.prospectors =\> filebeat.inputs). But I cannot get the multililne config to parse correctly and I don't understand why. Do any of you understand? What have I missed?

```auto
  # Optional additional fields. These field can be freely picked
  # to add additional information to the crawled log files
  fields:
    log_type: strslog_application

  # Multiline
  multiline.pattern: '^([0-9]{4} [0-9]{6})'
  multiline.negate: true
  multiline.match: after​

```

File is in UTF-8 with unix line feed (LF). Everything works fine when removing the multiline config.

Error message is:

```nohighlight
2018-12-13T08:43:39.709+0100 ERROR instance/beat.go:800 Exiting: Error in initing input: unknown matcher type: a
fter​ accessing 'filebeat.inputs.0.multiline' (source:'filebeat.yml')
Exiting: Error in initing input: unknown matcher type: after​ accessing 'filebeat.inputs.0.multiline' (source:'filebeat.
yml')

```

---

<div class="post-metadata">

**Author:** ![pappaola](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@pappaola](https://discuss.elastic.co/u/pappaola)\
**Post date:** [December 13, 2018, 11:10am UTC](https://discuss.elastic.co/t/cannot-get-multiline-config-correct-in-6-5-1/160682/2 "2018-12-13T11:10:18Z")

</div>

Solved! This one one of the harder things to find out.

Finally I figured out that there was some hidden bytes in the file that you could only see in a hex editor.

![image](https://us1.discourse-cdn.com/elastic/original/3X/0/3/03d834ab531d3613b500f236adad8dcd0b215303.png)

Look at the four (4) last bytes `72 e2 80 8b`.  
`72` is `r` but `e2 80 8b` does not match any characters in the ASCII-table. See eg. [https://www.ibm.com/support/knowledgecenter/en/ssw\_aix\_72/com.ibm.aix.networkcomm/conversion\_table.htm](https://www.ibm.com/support/knowledgecenter/en/ssw_aix_72/com.ibm.aix.networkcomm/conversion_table.htm)

So by removing those bytes it now works!

_Note: that these bytes were also present in the question above_

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2019, 1:10pm UTC](https://discuss.elastic.co/t/cannot-get-multiline-config-correct-in-6-5-1/160682/3 "2019-01-10T13:10:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
