# Cannot get network drive connector to work

**URL:** <https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445>\
**Category:** Elastic Search\
**Tags:** elastic-workplace-search\
**Created:** [July 3, 2023, 11:01am UTC](https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445 "2023-07-03T11:01:26Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bairdy](https://avatars.discourse-cdn.com/v4/letter/b/43a26b/32.png) [@Bairdy](https://discuss.elastic.co/u/Bairdy)\
**Post date:** [July 3, 2023, 11:01am UTC](https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445/1 "2023-07-03T11:01:26Z")

</div>

Hi. I'm trying to get the network drive connector working in an offline environment (the first challenge was getting the thing made and portable but that's another issue). We do have an Enterprise licence but I don't believe I can access support for this issue as this connector is in beta, so raising it here.

I've managed to get it running on a Windows Server 2022 VM and configured as required against a Windows network share, but when I run it I'm getting the following error:

`smb.smb_structs.OperationFailure: Failed to list user1\files\data on data-share: Unable to connect to shared device`

I'm also seeing the following SMB header:

`SMB Header:`

`
`

`Command: 0x03 (SMB2_COM_TREE_CONNECT)
Status: 0xC0000022
`

According to MS SMB documentation the status implies that this is an 'Access Denied' error but all permissions are correct. I can login using the account in question and access the share without any problems so it doesn't appear to be a permissions issue.

I've set log\_level to DEBUG but I'm not seeing any additional information so not sure where to go from here. I'd really like to trial this connector in a proof-of-concept but this is proving difficult. Can anyone provide any pointers on this please?

---

<div class="post-metadata">

**Author:** ![Bairdy](https://avatars.discourse-cdn.com/v4/letter/b/43a26b/32.png) [@Bairdy](https://discuss.elastic.co/u/Bairdy)\
**Post date:** [July 3, 2023, 11:20am UTC](https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445/2 "2023-07-03T11:20:18Z")

</div>

Another few points:

If I change `network_drive.username` or `network_drive.password` to be invalid then I get a different error:

`Exception: Unkown error while connecting to the Network Drives`

I guess that sort of implies that the credentials are working as expected.

We also enforce NTLM2 only via Windows Group Policy and I've relaxed this to allow NTLM and NTLM2 but that doesn't' make any difference.

---

<div class="post-metadata">

**Author:** ![praveenkukreja](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/praveenkukreja/32/94046_2.png) [@praveenkukreja](https://discuss.elastic.co/u/praveenkukreja)\
**Post date:** [July 7, 2023, 7:43pm UTC](https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445/3 "2023-07-07T19:43:11Z")

</div>

Looking at the error, I think it's because some configurations are not correct. The `network_drive.server_name` is the System name found in the `System` info panel of Windows Server 2022 VM.  
The `network_drive.path` is the path **following** the server name in `Sharing` tab under `properties` of the share.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2023, 7:43pm UTC](https://discuss.elastic.co/t/cannot-get-network-drive-connector-to-work/337445/4 "2023-08-04T19:43:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
