# Cannot import elastic RPM GPG key on EL9

**URL:** <https://discuss.elastic.co/t/cannot-import-elastic-rpm-gpg-key-on-el9/306164>\
**Category:** Elasticsearch\
**Created:** [June 1, 2022, 9:32pm UTC](https://discuss.elastic.co/t/cannot-import-elastic-rpm-gpg-key-on-el9/306164 "2022-06-01T21:32:14Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![opoplawski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/opoplawski/32/40442_2.png) [@opoplawski](https://discuss.elastic.co/u/opoplawski)\
**Post date:** [June 1, 2022, 9:32pm UTC](https://discuss.elastic.co/t/cannot-import-elastic-rpm-gpg-key-on-el9/306164/1 "2022-06-01T21:32:14Z")

</div>

On AlmaLinux 9.0:

```auto
# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-elasticsearch
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-elasticsearch: key 1 import failed.

```

I believe this is due to newer restrictions on RPM GPG keys in EL9.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 29, 2022, 9:33pm UTC](https://discuss.elastic.co/t/cannot-import-elastic-rpm-gpg-key-on-el9/306164/2 "2022-06-29T21:33:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
