# Cannot install a \[platinum\] license unless TLS is configured or security is disabled

**URL:** https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193
**Category:** Elasticsearch
**Created:** [May 15, 2019, 12:40pm UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193 "2019-05-15T12:40:36Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 15, 2019, 12:40pm UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/1 "2019-05-15T12:40:36Z")

</div>

Hi

i couldnt able to update platinum license on the kibana console. shows \* Error encountered uploading license: Cannot install a [GOLD] license unless TLS is configured or security is disabled

so i tried to generate certs in elasticsearch server. my configuration below:

discovery.seed\_hosts: ["192.168.x.x", "192.168.x.x", "192.168.x.x"]  
cluster.initial\_master\_nodes: ["192.168.x.x", "192.168.x.x", "192.168.x.x"]  
#xpack.security.enabled: true

xpack.ssl.key: /etc/elasticsearch/certs/elastic/elastic.key  
xpack.ssl.certificate: /etc/elasticsearch/certs/elastic/elastic.crt  
xpack.ssl.certificate\_authorities: ["/etc/elasticsearch/certs/ca/ca.crt"]  
xpack.security.transport.ssl.enabled: true  
xpack.security.http.ssl.enabled: true

# restart the elasticsearch service , failed to start.

elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Thu 2019-05-16 04:33:04 +08; 3min 58s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 10270 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 10270 (code=exited, status=1/FAILURE)

May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.cli.Command.main(Command.java:90)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
May 16 04:33:04 elk-tst1 elasticsearch[10270]: Refer to the log for complete error details.  
May 16 04:33:04 elk-tst1 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
May 16 04:33:04 elk-tst1 systemd[1]: Unit elasticsearch.service entered failed state.  
May 16 04:33:04 elk-tst1 systemd[1]: elasticsearch.service failed.

can help out , what i did wrong...

thanks

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [May 16, 2019, 12:35am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/2 "2019-05-16T00:35:24Z")

</div>

Please always include your Elasticsearch version (run `elasticsearch --version`) in your posts. Knowing which version we're dealing with helps a lot.

> [@hari.v](#):
>
> ```
> May 16 04:33:04 elk-tst1 elasticsearch[10270]: Refer to the log for complete error details.
> 
> ```

You need to check your elasticsearch log file. The service logs will not contain enough information to diagnose the problems.

---

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 16, 2019, 5:04am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/3 "2019-05-16T05:04:27Z")

</div>

version: elasticsearch-7.0.0-1.x86\_64

after changing the file permission to 770 (elastic-certificates.p12) it works.

thanks

---

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 16, 2019, 6:48am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/4 "2019-05-16T06:48:26Z")

</div>

Hi

after i copied "elastic-certificates.p12" from elasticsearch node1 to elasticsearch node 2 server. elasticsearch clustering doesnt work.  
each elastic servers running individually. doesnt communicate each other.

other options i tried on the elasticsearch node2 server. generate node cert and restart elasticsearch service. still the same.

is there anything i missed out...

thanks

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [May 17, 2019, 12:59am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/5 "2019-05-17T00:59:30Z")

</div>

> [@hari.v](#):
>
> is there anything i missed out...

Since you haven't provided a list of the exact steps you followed, it's impossible for us to say.

If you want assistance, then it is in your interests to provide all necessary information so that we can try and work out what's going wrong. We need things like:

- Copies of any error message
- Relevant samples from log files
- A precise list of steps that you took

---

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 17, 2019, 2:21am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/6 "2019-05-17T02:21:13Z")

</div>

elasticsearch node1 logs:  
[2019-05-17T01:45:56,792][WARN][o.e.c.c.ClusterFormationFailureHelper] [node-1] master not discovered or elected yet, an election requires a node with id [CSUtQdiGRN2ojeOE87-XQw], have discovered [{node-2}{CSUtQdiGRN2ojeOE87-XQw}{OQOPYaLFS4-olmyCvcvkjg}{192.168.x.x}{192.168.x.x:9300}{ml.machine\_memory=1912078336, ml.max\_open\_jobs=20, xpack.installed=true}] which is a quorum; discovery will continue using [192.168.x.x:9300] from hosts providers and [{node-1}{TwzkNUqhQFWBYxf-gVEqBw}{bttbwCP1T2Cvv\_uC82zmyw}{192.168.x.x}{192.168.136.155:9300}{ml.machine\_memory=1912078336, xpack.installed=true, ml.max\_open\_jobs=20}] from last-known cluster state; node term 22, last-accepted version 30 in term 18

elasticsearch node2 log:

[2019-05-17T01:38:27,600][INFO][o.e.c.s.ClusterApplierService] [node-2] added {{node-1}{TwzkNUqhQFWBYxf-gVEqBw}{bttbwCP1T2Cvv\_uC82zmyw}{192.168.x.x}{192.168.136.155:9300}{ml.machine\_memory=1912078336, ml.max\_open\_jobs=20, xpack.installed=true},}, term: 22, version: 1431, reason: Publication{term=22, version=1431}  
[2019-05-17T01:38:27,659][WARN][o.e.g.G.InternalReplicaShardAllocator] [node-2] [.kibana\_task\_manager][0]: failed to list shard for shard\_store on node [TwzkNUqhQFWBYxf-gVEqBw]

elasticsearch cluster couldnt able to discover master node.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 14, 2019, 2:21am UTC](https://discuss.elastic.co/t/cannot-install-a-platinum-license-unless-tls-is-configured-or-security-is-disabled/181193/7 "2019-06-14T02:21:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
