# Cannot read property 'aliases' of undefined

**URL:** https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079
**Category:** Kibana
**Created:** [December 29, 2021, 1:50am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079 "2021-12-29T01:50:14Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![andrerca12](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrerca12/32/99625_2.png) [@andrerca12](https://discuss.elastic.co/u/andrerca12)
#### Post date: [December 29, 2021, 1:50am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/1 "2021-12-29T01:50:14Z")

</div>

Hello,

After i updated my Elasticsearch to version 7.16, Kibana can’t load Index Management page, with error  
Cannot read property ‘aliases’ of undefined.

Everything else is working fine, my applications are streaming logs to my indexes perfectly.  
Any ideas on how to fix it?

**Kibana version:** 7.9.2

**Elasticsearch version:** 7.16.2

**Server OS version:** Windows Server 2012 R2

**Browser version:** Chrome last version

**Browser OS version:** Chrome last version

**Original install method (e.g. download page, yum, from source, etc.):** Updated with MSI package

**Describe the bug:**  
After I updated Elasticsearch from 7.9 to 7.16 to fix log4j, Kibana can’t load Index Management page, with error  
Cannot read property ‘aliases’ of undefined.

Everything else is working fine, my applications are streaming logs to my indexes perfectly.  
Any ideas on how to fix it?

**Steps to reproduce:**

1. Update Elasticsearch
2. Open Index Management page

**Expected behavior:**  
Load indexes

**Provide logs and/or server output (if relevant):**

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36","referer":"[http://kibana5601/app/management/data/index\_management/indices"},"res":{"statusCode":500,"responseTime":280,"contentLength":9},"message":"GET](http://kibana5601/app/management/data/index_management/indices%22%7D,%22res%22:%7B%22statusCode%22:500,%22responseTime%22:280,%22contentLength%22:9%7D,%22message%22:%22GET) /api/index\_management/indices 500 280ms - 9.0B"}

---

<div class="post-metadata">

### Author: ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)
#### Post date: [December 30, 2021, 7:48am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/2 "2021-12-30T07:48:05Z")

</div>

Have you observed any errors during an upgrade? Is the index management the only page in Kibana that won't load?

---

<div class="post-metadata">

### Author: ![sumitgupta](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@sumitgupta](https://discuss.elastic.co/u/sumitgupta)
#### Post date: [January 12, 2022, 5:07am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/3 "2022-01-12T05:07:34Z")

</div>

We are also getting the same error when trying to load Index Management page. And there were no errors during upgrades. We upgraded ES 7.9.3 to 7.16.1.

We are getting error in all 4 instances of ES. Internal server error is received while Kibana is trying to reload the indices using API 'api/index\_management/indices/reload'

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/7/f7cc34db12112f7a71930b86687a8f65ed8a39bd.png)

Any help is appreciated.

---

<div class="post-metadata">

### Author: ![RapTvin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raptvin/32/86995_2.png) [@RapTvin](https://discuss.elastic.co/u/RapTvin)
#### Post date: [January 13, 2022, 7:48am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/4 "2022-01-13T07:48:39Z")

</div>

@sumitgupta did we find a solution this?

---

<div class="post-metadata">

### Author: ![sumitgupta](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@sumitgupta](https://discuss.elastic.co/u/sumitgupta)
#### Post date: [January 18, 2022, 7:36am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/5 "2022-01-18T07:36:29Z")

</div>

@RapTvin Not yet. Still waiting reply from Elastic team.

---

<div class="post-metadata">

### Author: ![sumitgupta](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@sumitgupta](https://discuss.elastic.co/u/sumitgupta)
#### Post date: [January 18, 2022, 7:38am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/6 "2022-01-18T07:38:00Z")

</div>

@majagrubic Were you able to reproduce this issue? Any solution yet?

---

<div class="post-metadata">

### Author: ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)
#### Post date: [January 18, 2022, 8:35am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/7 "2022-01-18T08:35:10Z")

</div>

This looks like a legitimate bug. Could you file a bug report [here](https://github.com/elastic/kibana/issues/new?assignees=&labels=bug&template=Bug_report.md), so that the appropriate team can have a look at it? Thanks

---

<div class="post-metadata">

### Author: ![andrerca12](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrerca12/32/99625_2.png) [@andrerca12](https://discuss.elastic.co/u/andrerca12)
#### Post date: [January 18, 2022, 2:09pm UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/8 "2022-01-18T14:09:29Z")

</div>

Hello everyone, i fixed it downgrading Kibana version from 7.9.3 to 7.8.1.  
You can also upgrade your Kibana to last version, but legacy plugins will not work

---

<div class="post-metadata">

### Author: ![RaonyO](https://avatars.discourse-cdn.com/v4/letter/r/5fc32e/32.png) [@RaonyO](https://discuss.elastic.co/u/RaonyO)
#### Post date: [January 18, 2022, 8:58pm UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/9 "2022-01-18T20:58:39Z")

</div>

Is there any other solution other than downgrading?

---

<div class="post-metadata">

### Author: ![John\_Murray](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_murray/32/100507_2.png) [@John\_Murray](https://discuss.elastic.co/u/John_Murray)
#### Post date: [January 19, 2022, 2:58am UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/10 "2022-01-19T02:58:05Z")

</div>

I saw the same problem in one of the clusters I manage (and not the other).  
Upgraded cluster on VM's to 7.16.2 (elastic and kibana) and it works  
Upgraded elastic on k8s to 7.16.3 using helm but inadvertently forgot to upgrade kibana to 7.16.3 - was 7.12.x and saw the issue. Once I upgraded kibana as well the issue went away.

Solution for me was to line up kibana version with elastic version, in my case upgrade

---

<div class="post-metadata">

### Author: ![sumitgupta](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@sumitgupta](https://discuss.elastic.co/u/sumitgupta)
#### Post date: [January 19, 2022, 4:43pm UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/11 "2022-01-19T16:43:35Z")

</div>

The key is to match the version of ES and Kibana. During ES upgrade to 7.16.1, I forgot to upgrade Kibana to the same version and hence the error. After upgrading Kibana to 7.16.1, there is no error. I think we should receive a warning or error while starting up Kibana when versions do not match.

My solution is same as @John_Murray

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 16, 2022, 4:44pm UTC](https://discuss.elastic.co/t/cannot-read-property-aliases-of-undefined/293079/12 "2022-02-16T16:44:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
