# Cannot register new repository \[local-backup\] failed to create repository

**URL:** <https://discuss.elastic.co/t/cannot-register-new-repository-local-backup-failed-to-create-repository/344632>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [October 9, 2023, 8:40am UTC](https://discuss.elastic.co/t/cannot-register-new-repository-local-backup-failed-to-create-repository/344632 "2023-10-09T08:40:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Keremcan\_Seker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/keremcan_seker/32/126097_2.png) [@Keremcan\_Seker](https://discuss.elastic.co/u/Keremcan_Seker)\
**Post date:** [October 9, 2023, 8:40am UTC](https://discuss.elastic.co/t/cannot-register-new-repository-local-backup-failed-to-create-repository/344632/1 "2023-10-09T08:40:27Z")

</div>

i'm getting this eroor while creating a repositry for backups in docker  
this is my settings on compose file

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/8/18afde6769dc7a02cf33f8301924b58f9009aabb.png)  
the path setting is on the bottom  
i saw from another elastic topic and created the backup directory and give it permission chmod 777  
and i still get the same error can you please help me

---

<div class="post-metadata">

**Author:** ![Keremcan\_Seker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/keremcan_seker/32/126097_2.png) [@Keremcan\_Seker](https://discuss.elastic.co/u/Keremcan_Seker)\
**Post date:** [October 9, 2023, 9:41am UTC](https://discuss.elastic.co/t/cannot-register-new-repository-local-backup-failed-to-create-repository/344632/2 "2023-10-09T09:41:26Z")

</div>

solved with adding settings to elasticsearch.yml  
path.repo: ["/usr/share/elasticsearch/backup"]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 6, 2023, 9:41am UTC](https://discuss.elastic.co/t/cannot-register-new-repository-local-backup-failed-to-create-repository/344632/3 "2023-11-06T09:41:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
